aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/profiles/zyxel.mk
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2010-04-18 16:24:12 +0000
committerGabor Juhos <juhosg@openwrt.org>2010-04-18 16:24:12 +0000
commitb6bd0ef6673964e5215d3c66de248f77e99b40e9 (patch)
tree7a99cfb316f5c4eca6e3f43764f4bcd72814968c /target/linux/ar71xx/profiles/zyxel.mk
parentdaa77559218206f4cfd8626d509ee30f181a60d6 (diff)
downloadmaster-187ad058-b6bd0ef6673964e5215d3c66de248f77e99b40e9.tar.gz
master-187ad058-b6bd0ef6673964e5215d3c66de248f77e99b40e9.tar.bz2
master-187ad058-b6bd0ef6673964e5215d3c66de248f77e99b40e9.zip
ar71xx: adding support for zyxel nbg460n/550n/550nh boards
This patch adds support for the zyxel nbg460n/550n/550nh routers. Currently this only works if a second stage bootloader is also flashed, as the used switch needs extra initialization. Signed-off-by: Michael Kurz <michi.kurz@googlemail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20990 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/profiles/zyxel.mk')
-rw-r--r--target/linux/ar71xx/profiles/zyxel.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/ar71xx/profiles/zyxel.mk b/target/linux/ar71xx/profiles/zyxel.mk
new file mode 100644
index 0000000000..73ae4e224c
--- /dev/null
+++ b/target/linux/ar71xx/profiles/zyxel.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/NBG_460N_550N_550NH
+ NAME:=Zyxel NBG 460N/550N/550NH
+ PACKAGES:=kmod-ath9k swconfig
+endef
+
+define Profile/NBG_460N_550N_550NH/Description
+ Package set optimized for the Zyxel NBG 460N/550N/550NH Routers.
+endef
+
+$(eval $(call Profile,NBG_460N_550N_550NH))