aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-4.1
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-11-21 21:24:18 +0000
committerJohn Crispin <blogic@openwrt.org>2015-11-21 21:24:18 +0000
commit86bd9c9d88b3516e9792ca33de1ba5f8788eea43 (patch)
treef1fe8b0f61fab09b36f0b27b06b398d5143579d2 /target/linux/ar71xx/patches-4.1
parent0e2e5556fa52a250d0acc374c7097a3be518a383 (diff)
downloadmaster-187ad058-86bd9c9d88b3516e9792ca33de1ba5f8788eea43.tar.gz
master-187ad058-86bd9c9d88b3516e9792ca33de1ba5f8788eea43.tar.bz2
master-187ad058-86bd9c9d88b3516e9792ca33de1ba5f8788eea43.zip
ar71xx: add support for the devolo dLAN Hotspot
Signed-off-by: Günther Kelleter <guenther.kelleter@devolo.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47554 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/patches-4.1')
-rw-r--r--target/linux/ar71xx/patches-4.1/700-MIPS-ath79-openwrt-machines.patch23
1 files changed, 17 insertions, 6 deletions
diff --git a/target/linux/ar71xx/patches-4.1/700-MIPS-ath79-openwrt-machines.patch b/target/linux/ar71xx/patches-4.1/700-MIPS-ath79-openwrt-machines.patch
index 66a3391076..ecba79fa65 100644
--- a/target/linux/ar71xx/patches-4.1/700-MIPS-ath79-openwrt-machines.patch
+++ b/target/linux/ar71xx/patches-4.1/700-MIPS-ath79-openwrt-machines.patch
@@ -1,6 +1,6 @@
--- a/arch/mips/ath79/machtypes.h
+++ b/arch/mips/ath79/machtypes.h
-@@ -16,24 +16,212 @@
+@@ -16,24 +16,213 @@
enum ath79_mach_type {
ATH79_MACH_GENERIC = 0,
@@ -43,6 +43,7 @@
+ ATH79_MACH_DIR_825_B1, /* D-Link DIR-825 rev. B1 */
+ ATH79_MACH_DIR_825_C1, /* D-Link DIR-825 rev. C1 */
+ ATH79_MACH_DIR_835_A1, /* D-Link DIR-835 rev. A1 */
++ ATH79_MACH_DLAN_HOTSPOT, /* devolo dLAN Hotspot */
+ ATH79_MACH_DLAN_PRO_500_WP, /* devolo dLAN pro 500 Wireless+ */
+ ATH79_MACH_DLAN_PRO_1200_AC, /* devolo dLAN pro 1200+ WiFi ac*/
+ ATH79_MACH_DRAGINO2, /* Dragino Version 2 */
@@ -306,7 +307,7 @@
config ATH79_MACH_AP121
bool "Atheros AP121 reference board"
select SOC_AR933X
-@@ -11,62 +95,1116 @@ config ATH79_MACH_AP121
+@@ -11,62 +95,1125 @@ config ATH79_MACH_AP121
select ATH79_DEV_M25P80
select ATH79_DEV_USB
select ATH79_DEV_WMAC
@@ -679,6 +680,15 @@
+ select ATH79_DEV_USB
+ select ATH79_DEV_WMAC
+
++config ATH79_MACH_DLAN_HOTSPOT
++ bool "devolo dLAN Hotspot support"
++ select SOC_AR933X
++ select ATH79_DEV_ETH
++ select ATH79_DEV_GPIO_BUTTONS
++ select ATH79_DEV_LEDS_GPIO
++ select ATH79_DEV_M25P80
++ select ATH79_DEV_WMAC
++
+config ATH79_MACH_DLAN_PRO_500_WP
+ bool "devolo dLAN pro 500 Wireless+ support"
+ select SOC_AR934X
@@ -1452,7 +1462,7 @@
config ATH79_MACH_UBNT_XM
bool "Ubiquiti Networks XM/UniFi boards"
-@@ -83,6 +1221,116 @@ config ATH79_MACH_UBNT_XM
+@@ -83,6 +1230,116 @@ config ATH79_MACH_UBNT_XM
Say 'Y' here if you want your kernel to support the
Ubiquiti Networks XM (rev 1.0) board.
@@ -1569,7 +1579,7 @@
endmenu
config SOC_AR71XX
-@@ -134,7 +1382,10 @@ config ATH79_DEV_DSA
+@@ -134,7 +1391,10 @@ config ATH79_DEV_DSA
config ATH79_DEV_ETH
def_bool n
@@ -1581,7 +1591,7 @@
def_bool n
config ATH79_DEV_GPIO_BUTTONS
-@@ -164,6 +1415,11 @@ config ATH79_PCI_ATH9K_FIXUP
+@@ -164,6 +1424,11 @@ config ATH79_PCI_ATH9K_FIXUP
def_bool n
config ATH79_ROUTERBOOT
@@ -1595,7 +1605,7 @@
endif
--- a/arch/mips/ath79/Makefile
+++ b/arch/mips/ath79/Makefile
-@@ -38,9 +38,136 @@ obj-$(CONFIG_ATH79_ROUTERBOOT) += route
+@@ -38,9 +38,137 @@ obj-$(CONFIG_ATH79_ROUTERBOOT) += route
#
# Machines
#
@@ -1620,6 +1630,7 @@
+obj-$(CONFIG_ATH79_MACH_CF_E316N_V2) += mach-cf-e316n-v2.o
+obj-$(CONFIG_ATH79_MACH_CPE510) += mach-cpe510.o
obj-$(CONFIG_ATH79_MACH_DB120) += mach-db120.o
++obj-$(CONFIG_ATH79_MACH_DLAN_HOTSPOT) += mach-dlan-hotspot.o
+obj-$(CONFIG_ATH79_MACH_DLAN_PRO_500_WP) += mach-dlan-pro-500-wp.o
+obj-$(CONFIG_ATH79_MACH_DLAN_PRO_1200_AC) += mach-dlan-pro-1200-ac.o
+obj-$(CONFIG_ATH79_MACH_DGL_5500_A1) += mach-dgl-5500-a1.o