aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-4.1
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-09-24 09:08:47 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-09-24 09:08:47 +0000
commit7812e20294d54c4b47b4fa05c9970c33bced1293 (patch)
treee61c8deefaa56e45b91ec8e355c9b6cc3a70908a /target/linux/ar71xx/patches-4.1
parent7c3c0c99892aa3a176eb5142d04649b99840a1a4 (diff)
downloadmaster-187ad058-7812e20294d54c4b47b4fa05c9970c33bced1293.tar.gz
master-187ad058-7812e20294d54c4b47b4fa05c9970c33bced1293.tar.bz2
master-187ad058-7812e20294d54c4b47b4fa05c9970c33bced1293.zip
ar71xx: Add WeIO Board Support
Add support for WeIO board (http://we-io.net). This board is based on Carambola2 board form 8Devices. Signed-off-by: Drasko DRASKOVIC <drasko.draskovic@gmail.com> Signed-off-by: Felix Fietkau <nbd@openwrt.org> [some cleanups] git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47036 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/patches-4.1')
-rw-r--r--target/linux/ar71xx/patches-4.1/700-MIPS-ath79-openwrt-machines.patch21
1 files changed, 16 insertions, 5 deletions
diff --git a/target/linux/ar71xx/patches-4.1/700-MIPS-ath79-openwrt-machines.patch b/target/linux/ar71xx/patches-4.1/700-MIPS-ath79-openwrt-machines.patch
index 020bdfeffc..8ee0d3f6dc 100644
--- a/target/linux/ar71xx/patches-4.1/700-MIPS-ath79-openwrt-machines.patch
+++ b/target/linux/ar71xx/patches-4.1/700-MIPS-ath79-openwrt-machines.patch
@@ -1,6 +1,6 @@
--- a/arch/mips/ath79/machtypes.h
+++ b/arch/mips/ath79/machtypes.h
-@@ -16,24 +16,209 @@
+@@ -16,24 +16,210 @@
enum ath79_mach_type {
ATH79_MACH_GENERIC = 0,
@@ -178,6 +178,7 @@
ATH79_MACH_UBNT_UNIFI_OUTDOOR, /* Ubiquiti UnifiAP Outdoor */
+ ATH79_MACH_UBNT_UNIFI_OUTDOOR_PLUS, /* Ubiquiti UnifiAP Outdoor+ */
ATH79_MACH_UBNT_XM, /* Ubiquiti Networks XM board rev 1.0 */
++ ATH79_MACH_WEIO, /* WeIO board */
+ ATH79_MACH_WHR_G301N, /* Buffalo WHR-G301N */
+ ATH79_MACH_WHR_HP_G300N, /* Buffalo WHR-HP-G300N */
+ ATH79_MACH_WHR_HP_GN, /* Buffalo WHR-HP-GN */
@@ -1439,10 +1440,19 @@
config ATH79_MACH_UBNT_XM
bool "Ubiquiti Networks XM/UniFi boards"
-@@ -83,6 +1212,107 @@ config ATH79_MACH_UBNT_XM
+@@ -83,6 +1212,116 @@ config ATH79_MACH_UBNT_XM
Say 'Y' here if you want your kernel to support the
Ubiquiti Networks XM (rev 1.0) board.
++config ATH79_MACH_WEIO
++ bool "WeIO board"
++ select SOC_AR933X
++ select ATH79_DEV_GPIO_BUTTONS
++ select ATH79_DEV_LEDS_GPIO
++ select ATH79_DEV_M25P80
++ select ATH79_DEV_USB
++ select ATH79_DEV_WMAC
++
+config ATH79_MACH_MYNET_N600
+ bool "WD My Net N600 board support"
+ select SOC_AR934X
@@ -1547,7 +1557,7 @@
endmenu
config SOC_AR71XX
-@@ -134,7 +1364,10 @@ config ATH79_DEV_DSA
+@@ -134,7 +1373,10 @@ config ATH79_DEV_DSA
config ATH79_DEV_ETH
def_bool n
@@ -1559,7 +1569,7 @@
def_bool n
config ATH79_DEV_GPIO_BUTTONS
-@@ -164,6 +1397,11 @@ config ATH79_PCI_ATH9K_FIXUP
+@@ -164,6 +1406,11 @@ config ATH79_PCI_ATH9K_FIXUP
def_bool n
config ATH79_ROUTERBOOT
@@ -1573,7 +1583,7 @@
endif
--- a/arch/mips/ath79/Makefile
+++ b/arch/mips/ath79/Makefile
-@@ -38,9 +38,134 @@ obj-$(CONFIG_ATH79_ROUTERBOOT) += route
+@@ -38,9 +38,135 @@ obj-$(CONFIG_ATH79_ROUTERBOOT) += route
#
# Machines
#
@@ -1683,6 +1693,7 @@
+obj-$(CONFIG_ATH79_MACH_TUBE2H) += mach-tube2h.o
+obj-$(CONFIG_ATH79_MACH_UBNT) += mach-ubnt.o
obj-$(CONFIG_ATH79_MACH_UBNT_XM) += mach-ubnt-xm.o
++obj-$(CONFIG_ATH79_MACH_WEIO) += mach-weio.o
+obj-$(CONFIG_ATH79_MACH_WHR_HP_G300N) += mach-whr-hp-g300n.o
+obj-$(CONFIG_ATH79_MACH_WLAE_AG300N) += mach-wlae-ag300n.o
+obj-$(CONFIG_ATH79_MACH_WLR8100) += mach-wlr8100.o