aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-4.1
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-12-11 15:04:47 +0000
committerJohn Crispin <blogic@openwrt.org>2015-12-11 15:04:47 +0000
commit6c8c0504855e51cca630dcb805156ddbf2404356 (patch)
tree8a27150d47f1d2cd969cfcd6cb810f5e4c50bddc /target/linux/ar71xx/patches-4.1
parent9578043ce985f1ab05ab9a558b4e2e46d0b1d728 (diff)
downloadmaster-187ad058-6c8c0504855e51cca630dcb805156ddbf2404356.tar.gz
master-187ad058-6c8c0504855e51cca630dcb805156ddbf2404356.tar.bz2
master-187ad058-6c8c0504855e51cca630dcb805156ddbf2404356.zip
ar71xx: Add support for Wallys DR344
This patch is for Wallys DR344 support under OpenWRT Signed-off-by: Philippe Duchein <wireless-dev@duchein.net> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47847 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/patches-4.1')
-rw-r--r--target/linux/ar71xx/patches-4.1/702-MIPS-ath79-openwrt-dr344.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-4.1/702-MIPS-ath79-openwrt-dr344.patch b/target/linux/ar71xx/patches-4.1/702-MIPS-ath79-openwrt-dr344.patch
new file mode 100644
index 0000000000..23cada5570
--- /dev/null
+++ b/target/linux/ar71xx/patches-4.1/702-MIPS-ath79-openwrt-dr344.patch
@@ -0,0 +1,42 @@
+diff -Nru a/arch/mips/ath79/Kconfig b/arch/mips/ath79/Kconfig
+--- a/arch/mips/ath79/Kconfig 2015-10-27 22:09:32.705886861 +0100
++++ b/arch/mips/ath79/Kconfig 2015-10-27 22:16:08.822566162 +0100
+@@ -512,6 +512,16 @@
+ select ATH79_DEV_NFC
+ select ATH79_DEV_USB
+
++config ATH79_MACH_DR344
++ bool "Wallys DR344 board support"
++ select SOC_AS934X
++ select ATH79_DEV_ETH
++ select ATH79_DEV_GPIO_BUTTONS
++ select ATH79_DEV_LEDS_GPIO
++ select ATH79_DEV_M25P80
++ select ATH79_DEV_USB
++ select ATH79_DEV_WMAC
++
+ config ATH79_MACH_DRAGINO2
+ bool "DRAGINO V2 support"
+ select SOC_AR933X
+diff -Nru a/arch/mips/ath79/machtypes.h b/arch/mips/ath79/machtypes.h
+--- a/arch/mips/ath79/machtypes.h 2015-10-27 22:09:32.706886873 +0100
++++ b/arch/mips/ath79/machtypes.h 2015-10-27 22:12:28.011957673 +0100
+@@ -60,6 +60,7 @@
+ ATH79_MACH_DIR_835_A1, /* D-Link DIR-835 rev. A1 */
+ ATH79_MACH_DLAN_PRO_500_WP, /* devolo dLAN pro 500 Wireless+ */
+ ATH79_MACH_DLAN_PRO_1200_AC, /* devolo dLAN pro 1200+ WiFi ac*/
++ ATH79_MACH_DR344, /* Wallys DR344 */
+ ATH79_MACH_DRAGINO2, /* Dragino Version 2 */
+ ATH79_MACH_ESR900, /* EnGenius ESR900 */
+ ATH79_MACH_EW_DORIN, /* embedded wireless Dorin Platform */
+diff -Nru a/arch/mips/ath79/Makefile b/arch/mips/ath79/Makefile
+--- a/arch/mips/ath79/Makefile 2015-10-27 22:09:32.706886873 +0100
++++ b/arch/mips/ath79/Makefile 2015-10-27 22:17:18.716391867 +0100
+@@ -72,6 +72,7 @@
+ obj-$(CONFIG_ATH79_MACH_DIR_615_I1) += mach-dir-615-i1.o
+ obj-$(CONFIG_ATH79_MACH_DIR_825_B1) += mach-dir-825-b1.o
+ obj-$(CONFIG_ATH79_MACH_DIR_825_C1) += mach-dir-825-c1.o
++obj-$(CONFIG_ATH79_MACH_DR344) += mach-dr344.o
+ obj-$(CONFIG_ATH79_MACH_DRAGINO2) += mach-dragino2.o
+ obj-$(CONFIG_ATH79_MACH_ESR900) += mach-esr900.o
+ obj-$(CONFIG_ATH79_MACH_EW_DORIN) += mach-ew-dorin.o