aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-4.1/815-MIPS-ath79-add-ap152-support.patch
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-09-16 08:33:14 +0000
committerJohn Crispin <blogic@openwrt.org>2015-09-16 08:33:14 +0000
commitd45c9e48a3966a195e5b63ebccc64bfb8618086d (patch)
tree0b1a12de81a13887d5f06675953df3610dc53d57 /target/linux/ar71xx/patches-4.1/815-MIPS-ath79-add-ap152-support.patch
parent76686768b07fc121a37bef2eec4279ce78b94363 (diff)
downloadmaster-187ad058-d45c9e48a3966a195e5b63ebccc64bfb8618086d.tar.gz
master-187ad058-d45c9e48a3966a195e5b63ebccc64bfb8618086d.tar.bz2
master-187ad058-d45c9e48a3966a195e5b63ebccc64bfb8618086d.zip
ar71xx: add support for ap152 reference board
Signed-off-by: Miaoqing Pan <miaoqing@codeaurora.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46972 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/patches-4.1/815-MIPS-ath79-add-ap152-support.patch')
-rw-r--r--target/linux/ar71xx/patches-4.1/815-MIPS-ath79-add-ap152-support.patch43
1 files changed, 43 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-4.1/815-MIPS-ath79-add-ap152-support.patch b/target/linux/ar71xx/patches-4.1/815-MIPS-ath79-add-ap152-support.patch
new file mode 100644
index 0000000000..0b24886a22
--- /dev/null
+++ b/target/linux/ar71xx/patches-4.1/815-MIPS-ath79-add-ap152-support.patch
@@ -0,0 +1,43 @@
+--- a/arch/mips/ath79/Kconfig
++++ b/arch/mips/ath79/Kconfig
+@@ -151,6 +151,20 @@ config ATH79_MACH_AP147
+ Say 'Y' here if you want your kernel to support the
+ QCA AP147 reference boards.
+
++config ATH79_MACH_AP152
++ bool "Atheros AP152 reference board"
++ select SOC_QCA956X
++ select ATH79_DEV_GPIO_BUTTONS
++ select ATH79_DEV_LEDS_GPIO
++ select ATH79_DEV_M25P80
++ select ATH79_DEV_USB
++ select ATH79_DEV_WMAC
++ select ATH79_DEV_AP9X_PCI if PCI
++ help
++ Say 'Y' here if you want your kernel to support the
++ QCA AP152 reference boards.
++
++
+ config ATH79_MACH_AP81
+ bool "Atheros AP81 reference board"
+ select SOC_AR913X
+--- a/arch/mips/ath79/Makefile
++++ b/arch/mips/ath79/Makefile
+@@ -50,6 +50,7 @@ obj-$(CONFIG_ATH79_MACH_AP132) += mach-ap132.o
+ obj-$(CONFIG_ATH79_MACH_AP136) += mach-ap136.o
+ obj-$(CONFIG_ATH79_MACH_AP143) += mach-ap143.o
+ obj-$(CONFIG_ATH79_MACH_AP147) += mach-ap147.o
++obj-$(CONFIG_ATH79_MACH_AP152) += mach-ap152.o
+ obj-$(CONFIG_ATH79_MACH_AP81) += mach-ap81.o
+ obj-$(CONFIG_ATH79_MACH_AP83) += mach-ap83.o
+ obj-$(CONFIG_ATH79_MACH_AP96) += mach-ap96.o
+--- a/arch/mips/ath79/machtypes.h
++++ b/arch/mips/ath79/machtypes.h
+@@ -32,6 +32,7 @@ enum ath79_mach_type {
+ ATH79_MACH_AP136_020, /* Atheros AP136-020 reference board */
+ ATH79_MACH_AP143, /* Atheros AP143 reference board */
+ ATH79_MACH_AP147_010, /* Atheros AP147-010 reference board */
++ ATH79_MACH_AP152, /* Atheros AP152 reference board */
+ ATH79_MACH_AP81, /* Atheros AP81 reference board */
+ ATH79_MACH_AP83, /* Atheros AP83 */
+ ATH79_MACH_AP96, /* Atheros AP96 */
ref='#n301'>301 302 303 304 305 306 307 308 309 310 311 312 313 314 315 316 317 318 319 320 321 322 323 324 325 326 327 328 329 330 331 332 333 334 335 336 337 338 339 340 341 342 343 344 345 346 347 348 349 350 351 352 353 354 355 356 357 358 359 360 361 362 363 364 365 366 367 368 369 370 371 372 373 374 375 376 377 378 379 380 381 382 383 384 385 386 387 388 389 390 391 392 393 394 395 396 397 398 399 400 401 402 403 404 405 406 407 408 409 410 411 412 413 414 415 416 417 418 419 420 421 422 423 424 425 426 427 428 429 430 431 432 433 434 435 436 437 438 439 440 441 442 443 444 445 446 447 448 449 450 451 452 453 454 455 456 457 458 459 460 461 462 463 464 465 466 467 468 469 470 471 472 473 474 475 476 477 478 479 480 481 482 483 484 485