aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-3.6/433-spi-rb4xx-cpld-driver.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-10-28 19:52:02 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-10-28 19:52:02 +0000
commita8ec452c60ed3281e29de6fa012f4940b4c3fbc3 (patch)
tree81e47efe735c4cde24370d77b47e0ab60a84c197 /target/linux/ar71xx/patches-3.6/433-spi-rb4xx-cpld-driver.patch
parentb783fb21a53535cf043189b0c4c30f315f494bb5 (diff)
downloadmaster-187ad058-a8ec452c60ed3281e29de6fa012f4940b4c3fbc3.tar.gz
master-187ad058-a8ec452c60ed3281e29de6fa012f4940b4c3fbc3.tar.bz2
master-187ad058-a8ec452c60ed3281e29de6fa012f4940b4c3fbc3.zip
ar71xx: add initial support for 3.6
The nand subtarget is not working yet. Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33983 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/patches-3.6/433-spi-rb4xx-cpld-driver.patch')
-rw-r--r--target/linux/ar71xx/patches-3.6/433-spi-rb4xx-cpld-driver.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-3.6/433-spi-rb4xx-cpld-driver.patch b/target/linux/ar71xx/patches-3.6/433-spi-rb4xx-cpld-driver.patch
new file mode 100644
index 0000000000..0d8cd99911
--- /dev/null
+++ b/target/linux/ar71xx/patches-3.6/433-spi-rb4xx-cpld-driver.patch
@@ -0,0 +1,26 @@
+--- a/drivers/spi/Kconfig
++++ b/drivers/spi/Kconfig
+@@ -479,6 +479,13 @@ config SPI_TLE62X0
+ sysfs interface, with each line presented as a kind of GPIO
+ exposing both switch control and diagnostic feedback.
+
++config SPI_RB4XX_CPLD
++ tristate "MikroTik RB4XX CPLD driver"
++ depends on ATH79_MACH_RB4XX
++ help
++ SPI driver for the Xilinx CPLD chip present on the
++ MikroTik RB4xx boards.
++
+ #
+ # Add new SPI protocol masters in alphabetical order above this line
+ #
+--- a/drivers/spi/Makefile
++++ b/drivers/spi/Makefile
+@@ -48,6 +48,7 @@ obj-$(CONFIG_SPI_PPC4xx) += spi-ppc4xx.
+ obj-$(CONFIG_SPI_PXA2XX) += spi-pxa2xx.o
+ obj-$(CONFIG_SPI_PXA2XX_PCI) += spi-pxa2xx-pci.o
+ obj-$(CONFIG_SPI_RB4XX) += spi-rb4xx.o
++obj-$(CONFIG_SPI_RB4XX_CPLD) += spi-rb4xx-cpld.o
+ obj-$(CONFIG_SPI_RSPI) += spi-rspi.o
+ obj-$(CONFIG_SPI_S3C24XX) += spi-s3c24xx-hw.o
+ spi-s3c24xx-hw-y := spi-s3c24xx.o