aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-3.14/500-MIPS-fw-myloader.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-08-07 12:40:53 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-08-07 12:40:53 +0000
commitff536dcd1ca51df92622d7e9216e4cd908f07837 (patch)
tree678abd256de087993fc1dd84f181aacf099d5b04 /target/linux/ar71xx/patches-3.14/500-MIPS-fw-myloader.patch
parentce71c40c2491c5ce841e62b9ce0e73efb6339049 (diff)
downloadmaster-187ad058-ff536dcd1ca51df92622d7e9216e4cd908f07837.tar.gz
master-187ad058-ff536dcd1ca51df92622d7e9216e4cd908f07837.tar.bz2
master-187ad058-ff536dcd1ca51df92622d7e9216e4cd908f07837.zip
ar71xx: add linux 3.14 support
Signed-off-by: Zhao, Gang <gang.zhao.42@gmail.com> Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42038 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/patches-3.14/500-MIPS-fw-myloader.patch')
-rw-r--r--target/linux/ar71xx/patches-3.14/500-MIPS-fw-myloader.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-3.14/500-MIPS-fw-myloader.patch b/target/linux/ar71xx/patches-3.14/500-MIPS-fw-myloader.patch
new file mode 100644
index 0000000000..f62363a47c
--- /dev/null
+++ b/target/linux/ar71xx/patches-3.14/500-MIPS-fw-myloader.patch
@@ -0,0 +1,22 @@
+--- a/arch/mips/Makefile
++++ b/arch/mips/Makefile
+@@ -183,6 +183,7 @@ endif
+ #
+ libs-$(CONFIG_FW_ARC) += arch/mips/fw/arc/
+ libs-$(CONFIG_FW_CFE) += arch/mips/fw/cfe/
++libs-$(CONFIG_MYLOADER) += arch/mips/fw/myloader/
+ libs-$(CONFIG_FW_SNIPROM) += arch/mips/fw/sni/
+ libs-y += arch/mips/fw/lib/
+
+--- a/arch/mips/Kconfig
++++ b/arch/mips/Kconfig
+@@ -951,6 +951,9 @@ config MIPS_MSC
+ config MIPS_NILE4
+ bool
+
++config MYLOADER
++ bool
++
+ config SYNC_R4K
+ bool
+