aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-3.14/452-gpio-add-gpio-latch-driver.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-08-07 12:40:53 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-08-07 12:40:53 +0000
commitff536dcd1ca51df92622d7e9216e4cd908f07837 (patch)
tree678abd256de087993fc1dd84f181aacf099d5b04 /target/linux/ar71xx/patches-3.14/452-gpio-add-gpio-latch-driver.patch
parentce71c40c2491c5ce841e62b9ce0e73efb6339049 (diff)
downloadmaster-187ad058-ff536dcd1ca51df92622d7e9216e4cd908f07837.tar.gz
master-187ad058-ff536dcd1ca51df92622d7e9216e4cd908f07837.tar.bz2
master-187ad058-ff536dcd1ca51df92622d7e9216e4cd908f07837.zip
ar71xx: add linux 3.14 support
Signed-off-by: Zhao, Gang <gang.zhao.42@gmail.com> Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42038 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/patches-3.14/452-gpio-add-gpio-latch-driver.patch')
-rw-r--r--target/linux/ar71xx/patches-3.14/452-gpio-add-gpio-latch-driver.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-3.14/452-gpio-add-gpio-latch-driver.patch b/target/linux/ar71xx/patches-3.14/452-gpio-add-gpio-latch-driver.patch
new file mode 100644
index 0000000000..3029874d44
--- /dev/null
+++ b/target/linux/ar71xx/patches-3.14/452-gpio-add-gpio-latch-driver.patch
@@ -0,0 +1,22 @@
+--- a/drivers/gpio/Kconfig
++++ b/drivers/gpio/Kconfig
+@@ -842,4 +842,9 @@ config GPIO_NXP_74HC153
+ Platform driver for NXP 74HC153 Dual 4-input Multiplexer. This
+ provides a GPIO interface supporting input mode only.
+
++config GPIO_LATCH
++ tristate "GPIO latch driver"
++ help
++ Say yes here to enable a GPIO latch driver.
++
+ endif
+--- a/drivers/gpio/Makefile
++++ b/drivers/gpio/Makefile
+@@ -35,6 +35,7 @@ obj-$(CONFIG_GPIO_JANZ_TTL) += gpio-janz
+ obj-$(CONFIG_GPIO_KEMPLD) += gpio-kempld.o
+ obj-$(CONFIG_ARCH_KS8695) += gpio-ks8695.o
+ obj-$(CONFIG_GPIO_INTEL_MID) += gpio-intel-mid.o
++obj-$(CONFIG_GPIO_LATCH) += gpio-latch.o
+ obj-$(CONFIG_GPIO_LP3943) += gpio-lp3943.o
+ obj-$(CONFIG_ARCH_LPC32XX) += gpio-lpc32xx.o
+ obj-$(CONFIG_GPIO_LYNXPOINT) += gpio-lynxpoint.o