aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-3.10
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-10-30 06:50:54 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-10-30 06:50:54 +0000
commitf61c2c86637635682bddda91aa46eb013940f57d (patch)
tree31762d79e6a36cbb937a821ae6953c711923ad18 /target/linux/ar71xx/patches-3.10
parent7225a767f4d7e4707bf993c46695187e7a1cf0ed (diff)
downloadmaster-187ad058-f61c2c86637635682bddda91aa46eb013940f57d.tar.gz
master-187ad058-f61c2c86637635682bddda91aa46eb013940f57d.tar.bz2
master-187ad058-f61c2c86637635682bddda91aa46eb013940f57d.zip
ar71xx: add kernel support for the Sitecom WLR-8100 wireless router
- unsure about copyright message - based on AP136-010 Patchwork: http://patchwork.openwrt.org/patch/4147/ Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de> [juhosg: rename and refresh kernel patch] Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38589 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/patches-3.10')
-rw-r--r--target/linux/ar71xx/patches-3.10/630-MIPS-ath79-add-sc-wlr8100-support.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-3.10/630-MIPS-ath79-add-sc-wlr8100-support.patch b/target/linux/ar71xx/patches-3.10/630-MIPS-ath79-add-sc-wlr8100-support.patch
new file mode 100644
index 0000000000..369e1bafd3
--- /dev/null
+++ b/target/linux/ar71xx/patches-3.10/630-MIPS-ath79-add-sc-wlr8100-support.patch
@@ -0,0 +1,39 @@
+--- a/arch/mips/ath79/Kconfig
++++ b/arch/mips/ath79/Kconfig
+@@ -194,6 +194,16 @@ config ATH79_MACH_WLAE_AG300N
+ select ATH79_DEV_LEDS_GPIO
+ select ATH79_DEV_M25P80
+
++config ATH79_MACH_WLR8100
++ bool "Sitecom WLR-8100 board support"
++ select SOC_QCA955X
++ select ATH79_DEV_ETH
++ select ATH79_DEV_GPIO_BUTTONS
++ select ATH79_DEV_LEDS_GPIO
++ select ATH79_DEV_SPI
++ select ATH79_DEV_USB
++ select ATH79_DEV_WMAC
++
+ config ATH79_MACH_WZR_HP_AG300H
+ bool "Buffalo WZR-HP-AG300H board support"
+ select SOC_AR71XX
+--- a/arch/mips/ath79/machtypes.h
++++ b/arch/mips/ath79/machtypes.h
+@@ -128,6 +128,7 @@ enum ath79_mach_type {
+ ATH79_MACH_WHR_HP_G300N, /* Buffalo WHR-HP-G300N */
+ ATH79_MACH_WHR_HP_GN, /* Buffalo WHR-HP-GN */
+ ATH79_MACH_WLAE_AG300N, /* Buffalo WLAE-AG300N */
++ ATH79_MACH_WLR8100, /* SITECOM WLR-8100 */
+ ATH79_MACH_WNDAP360, /* NETGEAR WNDAP360 */
+ ATH79_MACH_WNDR3700, /* NETGEAR WNDR3700/WNDR3800/WNDRMAC */
+ ATH79_MACH_WNDR4300, /* NETGEAR WNDR4300 */
+--- a/arch/mips/ath79/Makefile
++++ b/arch/mips/ath79/Makefile
+@@ -104,6 +104,7 @@ obj-$(CONFIG_ATH79_MACH_UBNT) += mach-u
+ obj-$(CONFIG_ATH79_MACH_UBNT_XM) += mach-ubnt-xm.o
+ obj-$(CONFIG_ATH79_MACH_WHR_HP_G300N) += mach-whr-hp-g300n.o
+ obj-$(CONFIG_ATH79_MACH_WLAE_AG300N) += mach-wlae-ag300n.o
++obj-$(CONFIG_ATH79_MACH_WLR8100) += mach-wlr8100.o
+ obj-$(CONFIG_ATH79_MACH_WNDAP360) += mach-wndap360.o
+ obj-$(CONFIG_ATH79_MACH_WNDR3700) += mach-wndr3700.o
+ obj-$(CONFIG_ATH79_MACH_WNDR4300) += mach-wndr4300.o