aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-3.10
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-10-30 06:50:52 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-10-30 06:50:52 +0000
commitc8857f4ee7049675de0432812956539309e7ed68 (patch)
treeccddd19e212541ed70a074c42ffbdd79182d3140 /target/linux/ar71xx/patches-3.10
parenta1689c4bc6b269e911bb7bd6d5ffe08bf82cc0b0 (diff)
downloadmaster-187ad058-c8857f4ee7049675de0432812956539309e7ed68.tar.gz
master-187ad058-c8857f4ee7049675de0432812956539309e7ed68.tar.bz2
master-187ad058-c8857f4ee7049675de0432812956539309e7ed68.zip
ar71xx: add kernel support for DRAGINO2
This patch adds support for DRAGINO2 board (used by Meshpotato v2). Most of the files included can be found in the official svn repository provided by the company [1]. I have just adapt it to the last OpenWrt trunk revision (Fri Oct 4 10:49:47 2013). 1. http://svn.dragino.com/dragino2 Patchwork: http://patchwork.openwrt.org/patch/4234/ Signed-off-by: Pau Escrich <p4u@dabax.net> [juhosg: - rename and refresh kernel patch, - fix checkpatch warnings in mach-dragino2.c] Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38587 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/patches-3.10')
-rw-r--r--target/linux/ar71xx/patches-3.10/629-MIPS-ath79-add-dragino2-support.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-3.10/629-MIPS-ath79-add-dragino2-support.patch b/target/linux/ar71xx/patches-3.10/629-MIPS-ath79-add-dragino2-support.patch
new file mode 100644
index 0000000000..cc852e695d
--- /dev/null
+++ b/target/linux/ar71xx/patches-3.10/629-MIPS-ath79-add-dragino2-support.patch
@@ -0,0 +1,39 @@
+--- a/arch/mips/ath79/Kconfig
++++ b/arch/mips/ath79/Kconfig
+@@ -305,6 +305,16 @@ config ATH79_MACH_DIR_825_C1
+ select ATH79_DEV_USB
+ select ATH79_DEV_WMAC
+
++config ATH79_MACH_DRAGINO2
++ bool "DRAGINO V2 support"
++ select SOC_AR933X
++ select ATH79_DEV_M25P80
++ select ATH79_DEV_GPIO_BUTTONS
++ select ATH79_DEV_LEDS_GPIO
++ select ATH79_DEV_WMAC
++ select ATH79_DEV_ETH
++ select ATH79_DEV_USB
++
+ config ATH79_MACH_EW_DORIN
+ bool "embedded wireless Dorin Platform support"
+ select SOC_AR933X
+--- a/arch/mips/ath79/Makefile
++++ b/arch/mips/ath79/Makefile
+@@ -58,6 +58,7 @@ obj-$(CONFIG_ATH79_MACH_DIR_600_A1) += m
+ obj-$(CONFIG_ATH79_MACH_DIR_615_C1) += mach-dir-615-c1.o
+ obj-$(CONFIG_ATH79_MACH_DIR_825_B1) += mach-dir-825-b1.o
+ obj-$(CONFIG_ATH79_MACH_DIR_825_C1) += mach-dir-825-c1.o
++obj-$(CONFIG_ATH79_MACH_DRAGINO2) += mach-dragino2.o
+ obj-$(CONFIG_ATH79_MACH_EW_DORIN) += mach-ew-dorin.o
+ obj-$(CONFIG_ATH79_MACH_EAP7660D) += mach-eap7660d.o
+ obj-$(CONFIG_ATH79_MACH_JA76PF) += mach-ja76pf.o
+--- a/arch/mips/ath79/machtypes.h
++++ b/arch/mips/ath79/machtypes.h
+@@ -44,6 +44,7 @@ enum ath79_mach_type {
+ ATH79_MACH_DIR_825_B1, /* D-Link DIR-825 rev. B1 */
+ ATH79_MACH_DIR_825_C1, /* D-Link DIR-825 rev. C1 */
+ ATH79_MACH_DIR_835_A1, /* D-Link DIR-835 rev. A1 */
++ ATH79_MACH_DRAGINO2, /* Dragino Version 2 */
+ ATH79_MACH_EW_DORIN, /* embedded wireless Dorin Platform */
+ ATH79_MACH_EW_DORIN_ROUTER, /* embedded wireless Dorin Router Platform */
+ ATH79_MACH_EAP7660D, /* Senao EAP7660D */