aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-3.10
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2014-02-22 18:05:29 +0000
committerGabor Juhos <juhosg@openwrt.org>2014-02-22 18:05:29 +0000
commit1b9a85db8a5a6c63c50620768be1b31749f962e9 (patch)
tree0c14f4dbc3e8a5f7d61c7903448c1481bd7c6d1c /target/linux/ar71xx/patches-3.10
parent1a1595984e5d6b3b6ce755a593dbc8e53f524da8 (diff)
downloadmaster-187ad058-1b9a85db8a5a6c63c50620768be1b31749f962e9.tar.gz
master-187ad058-1b9a85db8a5a6c63c50620768be1b31749f962e9.tar.bz2
master-187ad058-1b9a85db8a5a6c63c50620768be1b31749f962e9.zip
ar71xx: add a generic GPIO latch driver
It will be used for the Mikrotik boards. Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39697 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/patches-3.10')
-rw-r--r--target/linux/ar71xx/patches-3.10/452-gpio-add-gpio-latch-driver.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-3.10/452-gpio-add-gpio-latch-driver.patch b/target/linux/ar71xx/patches-3.10/452-gpio-add-gpio-latch-driver.patch
new file mode 100644
index 0000000000..79ef548ed3
--- /dev/null
+++ b/target/linux/ar71xx/patches-3.10/452-gpio-add-gpio-latch-driver.patch
@@ -0,0 +1,22 @@
+--- a/drivers/gpio/Kconfig
++++ b/drivers/gpio/Kconfig
+@@ -725,4 +725,9 @@ config GPIO_NXP_74HC153
+ Platform driver for NXP 74HC153 Dual 4-input Multiplexer. This
+ provides a GPIO interface supporting input mode only.
+
++config GPIO_LATCH
++ tristate "GPIO latch driver"
++ help
++ Say yes here to enable a GPIO latch driver.
++
+ endif
+--- a/drivers/gpio/Makefile
++++ b/drivers/gpio/Makefile
+@@ -31,6 +31,7 @@ obj-$(CONFIG_GPIO_IT8761E) += gpio-it876
+ obj-$(CONFIG_GPIO_JANZ_TTL) += gpio-janz-ttl.o
+ obj-$(CONFIG_ARCH_KS8695) += gpio-ks8695.o
+ obj-$(CONFIG_GPIO_LANGWELL) += gpio-langwell.o
++obj-$(CONFIG_GPIO_LATCH) += gpio-latch.o
+ obj-$(CONFIG_ARCH_LPC32XX) += gpio-lpc32xx.o
+ obj-$(CONFIG_GPIO_LYNXPOINT) += gpio-lynxpoint.o
+ obj-$(CONFIG_GPIO_MAX730X) += gpio-max730x.o