aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-3.10/413-mtd-ar934x-nand-driver.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-09-19 18:43:41 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-09-19 18:43:41 +0000
commit01b9f2ed810fba324eb4c42d61ae4b21c1730721 (patch)
tree089ba705b76933110ccf575834ff5e92a4814dfc /target/linux/ar71xx/patches-3.10/413-mtd-ar934x-nand-driver.patch
parent71d579ba28ea4052f5baf46ceb08799602a3f3ee (diff)
downloadmaster-187ad058-01b9f2ed810fba324eb4c42d61ae4b21c1730721.tar.gz
master-187ad058-01b9f2ed810fba324eb4c42d61ae4b21c1730721.tar.bz2
master-187ad058-01b9f2ed810fba324eb4c42d61ae4b21c1730721.zip
ar71xx: ar934x_nfc: add experimental support for hardware ECC
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38069 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/patches-3.10/413-mtd-ar934x-nand-driver.patch')
-rw-r--r--target/linux/ar71xx/patches-3.10/413-mtd-ar934x-nand-driver.patch6
1 files changed, 5 insertions, 1 deletions
diff --git a/target/linux/ar71xx/patches-3.10/413-mtd-ar934x-nand-driver.patch b/target/linux/ar71xx/patches-3.10/413-mtd-ar934x-nand-driver.patch
index d7107b0b68..17595368f9 100644
--- a/target/linux/ar71xx/patches-3.10/413-mtd-ar934x-nand-driver.patch
+++ b/target/linux/ar71xx/patches-3.10/413-mtd-ar934x-nand-driver.patch
@@ -1,6 +1,6 @@
--- a/drivers/mtd/nand/Kconfig
+++ b/drivers/mtd/nand/Kconfig
-@@ -552,4 +552,8 @@ config MTD_NAND_RB750
+@@ -552,4 +552,12 @@ config MTD_NAND_RB750
tristate "NAND flash driver for the RouterBoard 750"
depends on MTD_NAND && ATH79_MACH_RB750
@@ -8,6 +8,10 @@
+ tristate "NAND flash driver for the Qualcomm Atheros AR934x/QCA955x SoCs"
+ depends on (SOC_AR934X || SOC_QCA955X)
+
++config MTD_NAND_AR934X_HW_ECC
++ bool "Hardware ECC support for the AR934X NAND Controller (EXPERIMENTAL)"
++ depends on MTD_NAND_AR934X
++
endif # MTD_NAND
--- a/drivers/mtd/nand/Makefile
+++ b/drivers/mtd/nand/Makefile