aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.39
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2011-12-03 18:13:27 +0000
committerGabor Juhos <juhosg@openwrt.org>2011-12-03 18:13:27 +0000
commitdc7ac758419b6a3ba5611b6ee4bf99d37887dc37 (patch)
tree4eb781a4b9758c3d89b1562956050a307cc89dc5 /target/linux/ar71xx/patches-2.6.39
parentf91daa748688ba733fbfe9213452ab43580fa730 (diff)
downloadmaster-187ad058-dc7ac758419b6a3ba5611b6ee4bf99d37887dc37.tar.gz
master-187ad058-dc7ac758419b6a3ba5611b6ee4bf99d37887dc37.tar.bz2
master-187ad058-dc7ac758419b6a3ba5611b6ee4bf99d37887dc37.zip
ar71xx: add mtd partition parser for the TP-Link boards
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29415 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.39')
-rw-r--r--target/linux/ar71xx/patches-2.6.39/112-mtd-tp-link-partition-parser.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-2.6.39/112-mtd-tp-link-partition-parser.patch b/target/linux/ar71xx/patches-2.6.39/112-mtd-tp-link-partition-parser.patch
new file mode 100644
index 0000000000..90bdfc9d4c
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.39/112-mtd-tp-link-partition-parser.patch
@@ -0,0 +1,25 @@
+--- a/drivers/mtd/Kconfig
++++ b/drivers/mtd/Kconfig
+@@ -198,6 +198,12 @@ config MTD_MYLOADER_PARTS
+ You will still need the parsing functions to be called by the driver
+ for your particular device. It won't happen automatically.
+
++config MTD_TPLINK_PARTS
++ tristate "TP-Link AR7XXX/AR9XXX partitioning support"
++ depends on MTD_PARTITIONS && ATHEROS_AR71XX
++ ---help---
++ TBD.
++
+ comment "User Modules And Translation Layers"
+
+ config MTD_CHAR
+--- a/drivers/mtd/Makefile
++++ b/drivers/mtd/Makefile
+@@ -14,6 +14,7 @@ obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
+ obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o
+ obj-$(CONFIG_MTD_WRT160NL_PARTS) += wrt160nl_part.o
+ obj-$(CONFIG_MTD_MYLOADER_PARTS) += myloader.o
++obj-$(CONFIG_MTD_TPLINK_PARTS) += tplinkpart.o
+
+ # 'Users' - code which presents functionality to userspace.
+ obj-$(CONFIG_MTD_CHAR) += mtdchar.o