aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.37/203-pb44_spi_controller.patch
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-11-10 16:23:42 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-11-10 16:23:42 +0000
commit283e5476068c9072e4416e0b3181be2a3c5f2a93 (patch)
tree9faac6512fdb7dc7b2bc41ebd9ae8fcbb341aa7e /target/linux/ar71xx/patches-2.6.37/203-pb44_spi_controller.patch
parentae3afbb5cadd9901c5f9d8a82e9248e3c9de405f (diff)
downloadmaster-187ad058-283e5476068c9072e4416e0b3181be2a3c5f2a93.tar.gz
master-187ad058-283e5476068c9072e4416e0b3181be2a3c5f2a93.tar.bz2
master-187ad058-283e5476068c9072e4416e0b3181be2a3c5f2a93.zip
linux/ar71xx: add preliminary 2.6.37 kernel support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@23944 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.37/203-pb44_spi_controller.patch')
-rw-r--r--target/linux/ar71xx/patches-2.6.37/203-pb44_spi_controller.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-2.6.37/203-pb44_spi_controller.patch b/target/linux/ar71xx/patches-2.6.37/203-pb44_spi_controller.patch
new file mode 100644
index 0000000000..9973874e9e
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.37/203-pb44_spi_controller.patch
@@ -0,0 +1,27 @@
+--- a/drivers/spi/Kconfig
++++ b/drivers/spi/Kconfig
+@@ -68,6 +68,14 @@ config SPI_AR71XX
+ help
+ This is the SPI contoller driver for Atheros AR71xx.
+
++config SPI_PB44
++ tristate "Atheros PB44 board specific SPI controller"
++ depends on SPI_MASTER && AR71XX_MACH_PB44
++ select SPI_BITBANG
++ help
++ This is a specific SPI controller driver for the Atheros PB44
++ reference board.
++
+ config SPI_ATMEL
+ tristate "Atmel SPI Controller"
+ depends on (ARCH_AT91 || AVR32)
+--- a/drivers/spi/Makefile
++++ b/drivers/spi/Makefile
+@@ -26,6 +26,7 @@ obj-$(CONFIG_SPI_GPIO) += spi_gpio.o
+ obj-$(CONFIG_SPI_GPIO_OLD) += spi_gpio_old.o
+ obj-$(CONFIG_SPI_IMX) += spi_imx.o
+ obj-$(CONFIG_SPI_LM70_LLP) += spi_lm70llp.o
++obj-$(CONFIG_SPI_PB44) += pb44_spi.o
+ obj-$(CONFIG_SPI_PXA2XX) += pxa2xx_spi.o
+ obj-$(CONFIG_SPI_OMAP_UWIRE) += omap_uwire.o
+ obj-$(CONFIG_SPI_OMAP24XX) += omap2_mcspi.o