aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.37/202-spi_vsc7385_driver.patch
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-11-10 16:23:42 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-11-10 16:23:42 +0000
commit283e5476068c9072e4416e0b3181be2a3c5f2a93 (patch)
tree9faac6512fdb7dc7b2bc41ebd9ae8fcbb341aa7e /target/linux/ar71xx/patches-2.6.37/202-spi_vsc7385_driver.patch
parentae3afbb5cadd9901c5f9d8a82e9248e3c9de405f (diff)
downloadmaster-187ad058-283e5476068c9072e4416e0b3181be2a3c5f2a93.tar.gz
master-187ad058-283e5476068c9072e4416e0b3181be2a3c5f2a93.tar.bz2
master-187ad058-283e5476068c9072e4416e0b3181be2a3c5f2a93.zip
linux/ar71xx: add preliminary 2.6.37 kernel support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@23944 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.37/202-spi_vsc7385_driver.patch')
-rw-r--r--target/linux/ar71xx/patches-2.6.37/202-spi_vsc7385_driver.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-2.6.37/202-spi_vsc7385_driver.patch b/target/linux/ar71xx/patches-2.6.37/202-spi_vsc7385_driver.patch
new file mode 100644
index 0000000000..4fb7c1d7ac
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.37/202-spi_vsc7385_driver.patch
@@ -0,0 +1,24 @@
+--- a/drivers/spi/Kconfig
++++ b/drivers/spi/Kconfig
+@@ -461,6 +461,11 @@ config SPI_RB4XX_CPLD
+ SPI driver for the Xilinx CPLD chip present on the
+ MikroTik RB4xx boards.
+
++config SPI_VSC7385
++ tristate "Vitesse VSC7385 ethernet switch driver"
++ help
++ SPI driver for the Vitesse VSC7385 ethernet switch.
++
+ #
+ # Add new SPI protocol masters in alphabetical order above this line
+ #
+--- a/drivers/spi/Makefile
++++ b/drivers/spi/Makefile
+@@ -63,6 +63,7 @@ spi_s3c24xx_hw-$(CONFIG_SPI_S3C24XX_FIQ)
+ # SPI protocol drivers (device/link on bus)
+ obj-$(CONFIG_SPI_RB4XX_CPLD) += spi_rb4xx_cpld.o
+ obj-$(CONFIG_SPI_SPIDEV) += spidev.o
++obj-$(CONFIG_SPI_VSC7385) += spi_vsc7385.o
+ obj-$(CONFIG_SPI_TLE62X0) += tle62x0.o
+ # ... add above this line ...
+