aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.36/152-rb4xx-spi-driver.patch
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-10-08 12:10:18 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-10-08 12:10:18 +0000
commitff0ca066b820c970c900187d960f89c0506ea9d5 (patch)
tree059ad1fcf4d3fb24797ef02b4f4d92d5f74817a1 /target/linux/ar71xx/patches-2.6.36/152-rb4xx-spi-driver.patch
parent03965bd6f312c14c35512aae8c0c1393ca662dbe (diff)
downloadmaster-187ad058-ff0ca066b820c970c900187d960f89c0506ea9d5.tar.gz
master-187ad058-ff0ca066b820c970c900187d960f89c0506ea9d5.tar.bz2
master-187ad058-ff0ca066b820c970c900187d960f89c0506ea9d5.zip
linux/ar71xx: add preliminary 2.6.36 kernel support (refresh patches)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@23317 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.36/152-rb4xx-spi-driver.patch')
-rw-r--r--target/linux/ar71xx/patches-2.6.36/152-rb4xx-spi-driver.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-2.6.36/152-rb4xx-spi-driver.patch b/target/linux/ar71xx/patches-2.6.36/152-rb4xx-spi-driver.patch
new file mode 100644
index 0000000000..1a59b44387
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.36/152-rb4xx-spi-driver.patch
@@ -0,0 +1,25 @@
+--- a/drivers/spi/Kconfig
++++ b/drivers/spi/Kconfig
+@@ -259,6 +259,12 @@ config SPI_PXA2XX
+ The driver can be configured to use any SSP port and additional
+ documentation can be found a Documentation/spi/pxa2xx.
+
++config SPI_RB4XX
++ tristate "Mikrotik RB4XX SPI master"
++ depends on SPI_MASTER && AR71XX_MACH_RB4XX
++ help
++ SPI controller driver for the Mikrotik RB4xx series boards.
++
+ config SPI_S3C24XX
+ tristate "Samsung S3C24XX series SPI"
+ depends on ARCH_S3C2410 && EXPERIMENTAL
+--- a/drivers/spi/Makefile
++++ b/drivers/spi/Makefile
+@@ -49,6 +49,7 @@ obj-$(CONFIG_SPI_SH_SCI) += spi_sh_sci.
+ obj-$(CONFIG_SPI_SH_MSIOF) += spi_sh_msiof.o
+ obj-$(CONFIG_SPI_STMP3XXX) += spi_stmp.o
+ obj-$(CONFIG_SPI_NUC900) += spi_nuc900.o
++obj-$(CONFIG_SPI_RB4XX) += rb4xx_spi.o
+
+ # special build for s3c24xx spi driver with fiq support
+ spi_s3c24xx_hw-y := spi_s3c24xx.o