aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.32
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2010-01-25 15:13:38 +0000
committerGabor Juhos <juhosg@openwrt.org>2010-01-25 15:13:38 +0000
commite97e8ca04c59387c42896ffa225e130286f2f0be (patch)
tree8e2cf6485ae203c92ca5e7092bc9d82e74b8e10e /target/linux/ar71xx/patches-2.6.32
parent2e49de5379e7157adfee64378866d4447ffb9338 (diff)
downloadmaster-187ad058-e97e8ca04c59387c42896ffa225e130286f2f0be.tar.gz
master-187ad058-e97e8ca04c59387c42896ffa225e130286f2f0be.tar.bz2
master-187ad058-e97e8ca04c59387c42896ffa225e130286f2f0be.zip
rtl8366: make it available on all platforms
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19329 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.32')
-rw-r--r--target/linux/ar71xx/patches-2.6.32/101-ksz8041_phy_driver.patch6
-rw-r--r--target/linux/ar71xx/patches-2.6.32/204-rtl8366-smi-driver.patch39
2 files changed, 3 insertions, 42 deletions
diff --git a/target/linux/ar71xx/patches-2.6.32/101-ksz8041_phy_driver.patch b/target/linux/ar71xx/patches-2.6.32/101-ksz8041_phy_driver.patch
index 866b50386a..94193e8554 100644
--- a/target/linux/ar71xx/patches-2.6.32/101-ksz8041_phy_driver.patch
+++ b/target/linux/ar71xx/patches-2.6.32/101-ksz8041_phy_driver.patch
@@ -14,9 +14,9 @@
depends on PHYLIB=y
--- a/drivers/net/phy/Makefile
+++ b/drivers/net/phy/Makefile
-@@ -21,6 +21,7 @@ obj-$(CONFIG_REALTEK_PHY) += realtek.o
- obj-$(CONFIG_AR8216_PHY) += ar8216.o
- obj-$(CONFIG_RTL8306_PHY) += rtl8306.o
+@@ -23,6 +23,7 @@ obj-$(CONFIG_RTL8306_PHY) += rtl8306.o
+ obj-$(CONFIG_RTL8366_SMI) += rtl8366_smi.o
+ obj-$(CONFIG_RTL8366S_PHY) += rtl8366s.o
obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+obj-$(CONFIG_MICREL) += micrel.o
obj-$(CONFIG_FIXED_PHY) += fixed.o
diff --git a/target/linux/ar71xx/patches-2.6.32/204-rtl8366-smi-driver.patch b/target/linux/ar71xx/patches-2.6.32/204-rtl8366-smi-driver.patch
deleted file mode 100644
index fbd52c3b78..0000000000
--- a/target/linux/ar71xx/patches-2.6.32/204-rtl8366-smi-driver.patch
+++ /dev/null
@@ -1,39 +0,0 @@
---- a/drivers/net/phy/Kconfig
-+++ b/drivers/net/phy/Kconfig
-@@ -146,4 +146,25 @@ config MDIO_GPIO
- To compile this driver as a module, choose M here: the module
- will be called mdio-gpio.
-
-+config RTL8366_SMI
-+ tristate "Driver for the RTL8366 SMI interface"
-+ depends on GENERIC_GPIO
-+ ---help---
-+ This module implements the SMI interface protocol which is used
-+ by some RTL8366 ethernet switch devices via the generic GPIO API.
-+
-+if RTL8366_SMI
-+
-+config RTL8366S_PHY
-+ tristate "Driver for the Realtek RTL8366S switch"
-+ select SWCONFIG
-+
-+config RTL8366S_PHY_DEBUG_FS
-+ bool "RTL8366S switch driver DEBUG_FS support"
-+ depends on RTL8366S_PHY
-+ depends on DEBUG_FS
-+ default n
-+
-+endif # RTL8366_SMI
-+
- endif # PHYLIB
---- a/drivers/net/phy/Makefile
-+++ b/drivers/net/phy/Makefile
-@@ -20,6 +20,8 @@ obj-$(CONFIG_IP175C_PHY) += ip175c.o
- obj-$(CONFIG_REALTEK_PHY) += realtek.o
- obj-$(CONFIG_AR8216_PHY) += ar8216.o
- obj-$(CONFIG_RTL8306_PHY) += rtl8306.o
-+obj-$(CONFIG_RTL8366_SMI) += rtl8366_smi.o
-+obj-$(CONFIG_RTL8366S_PHY) += rtl8366s.o
- obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
- obj-$(CONFIG_MICREL) += micrel.o
- obj-$(CONFIG_FIXED_PHY) += fixed.o