aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.32
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2010-01-15 12:07:58 +0000
committerGabor Juhos <juhosg@openwrt.org>2010-01-15 12:07:58 +0000
commita64c102618b460239efd7ce51dbda6cfebfd88bc (patch)
treeba4766b5da5a20d4a62ded937e4acf8efd8d38c8 /target/linux/ar71xx/patches-2.6.32
parent1edcc1f086259975e9f6f66227af37dcc26bd10f (diff)
downloadmaster-187ad058-a64c102618b460239efd7ce51dbda6cfebfd88bc.tar.gz
master-187ad058-a64c102618b460239efd7ce51dbda6cfebfd88bc.tar.bz2
master-187ad058-a64c102618b460239efd7ce51dbda6cfebfd88bc.zip
ar71xx: add GPIO driver for the NXP 74HC153 chip
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19149 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.32')
-rw-r--r--target/linux/ar71xx/patches-2.6.32/206-nxp-74hc153-gpio-chip-driver.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-2.6.32/206-nxp-74hc153-gpio-chip-driver.patch b/target/linux/ar71xx/patches-2.6.32/206-nxp-74hc153-gpio-chip-driver.patch
new file mode 100644
index 0000000000..1192d99ee0
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.32/206-nxp-74hc153-gpio-chip-driver.patch
@@ -0,0 +1,25 @@
+--- a/drivers/gpio/Kconfig
++++ b/drivers/gpio/Kconfig
+@@ -230,4 +230,12 @@ config GPIO_UCB1400
+ To compile this driver as a module, choose M here: the
+ module will be called ucb1400_gpio.
+
++comment "Other GPIO expanders"
++
++config GPIO_NXP_74HC153
++ tristate "NXP 74HC153 Dual 4-input multiplexer"
++ help
++ Platform driver for NXP 74HC153 Dual 4-input Multiplexer. This
++ provides a GPIO interface supporting inputs.
++
+ endif
+--- a/drivers/gpio/Makefile
++++ b/drivers/gpio/Makefile
+@@ -10,6 +10,7 @@ obj-$(CONFIG_GPIO_MAX7301) += max7301.o
+ obj-$(CONFIG_GPIO_MAX732X) += max732x.o
+ obj-$(CONFIG_GPIO_MC33880) += mc33880.o
+ obj-$(CONFIG_GPIO_MCP23S08) += mcp23s08.o
++obj-$(CONFIG_GPIO_NXP_74HC153) += nxp_74hc153.o
+ obj-$(CONFIG_GPIO_PCA953X) += pca953x.o
+ obj-$(CONFIG_GPIO_PCF857X) += pcf857x.o
+ obj-$(CONFIG_GPIO_PL061) += pl061.o