aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.32
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2010-03-08 12:10:01 +0000
committerGabor Juhos <juhosg@openwrt.org>2010-03-08 12:10:01 +0000
commit0d9be7212908591cda5e7ad54444261a0d34b7d6 (patch)
treed4110c2126f6edc187ec2826306ffc8b24a27183 /target/linux/ar71xx/patches-2.6.32
parenta950c66e0db961f735310caea115209b6a133a07 (diff)
downloadmaster-187ad058-0d9be7212908591cda5e7ad54444261a0d34b7d6.tar.gz
master-187ad058-0d9be7212908591cda5e7ad54444261a0d34b7d6.tar.bz2
master-187ad058-0d9be7212908591cda5e7ad54444261a0d34b7d6.zip
ar71xx: add LED driver for the RB750
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20051 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.32')
-rw-r--r--target/linux/ar71xx/patches-2.6.32/207-rb750-led-driver.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-2.6.32/207-rb750-led-driver.patch b/target/linux/ar71xx/patches-2.6.32/207-rb750-led-driver.patch
new file mode 100644
index 0000000000..a668c2c18f
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.32/207-rb750-led-driver.patch
@@ -0,0 +1,23 @@
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -243,6 +243,10 @@
+ This option enables support for the USB LED found on the
+ NETGEAR WNDR3700 board.
+
++config LEDS_RB750
++ tristate "LED driver for the Mikrotik RouterBOARD 750"
++ depends on LEDS_CLASS && AR71XX_MACH_RB750
++
+ comment "LED Triggers"
+
+ config LEDS_TRIGGERS
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -30,6 +30,7 @@
+ obj-$(CONFIG_LEDS_WM8350) += leds-wm8350.o
+ obj-$(CONFIG_LEDS_PWM) += leds-pwm.o
+ obj-${CONFIG_LEDS_WNDR3700_USB} += leds-wndr3700-usb.o
++obj-${CONFIG_LEDS_RB750} += leds-rb750.o
+
+ # LED SPI Drivers
+ obj-$(CONFIG_LEDS_DAC124S085) += leds-dac124s085.o