aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.32/202-spi_vsc7385_driver.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-12-04 20:27:03 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-12-04 20:27:03 +0000
commit34a28b34370830448d744f4bb5dd6905ffd3d9e2 (patch)
treef89dce2f46714984c00d784de052f9292aa8453a /target/linux/ar71xx/patches-2.6.32/202-spi_vsc7385_driver.patch
parentba3154ad3471bfb34b22d856b107348d7200fa9c (diff)
downloadmaster-187ad058-34a28b34370830448d744f4bb5dd6905ffd3d9e2.tar.gz
master-187ad058-34a28b34370830448d744f4bb5dd6905ffd3d9e2.tar.bz2
master-187ad058-34a28b34370830448d744f4bb5dd6905ffd3d9e2.zip
ar71xx: experimental 2.6.32 support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18638 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.32/202-spi_vsc7385_driver.patch')
-rw-r--r--target/linux/ar71xx/patches-2.6.32/202-spi_vsc7385_driver.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-2.6.32/202-spi_vsc7385_driver.patch b/target/linux/ar71xx/patches-2.6.32/202-spi_vsc7385_driver.patch
new file mode 100644
index 0000000000..a4b4595b04
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.32/202-spi_vsc7385_driver.patch
@@ -0,0 +1,24 @@
+--- a/drivers/spi/Kconfig
++++ b/drivers/spi/Kconfig
+@@ -296,6 +296,11 @@ config SPI_TLE62X0
+ sysfs interface, with each line presented as a kind of GPIO
+ exposing both switch control and diagnostic feedback.
+
++config SPI_VSC7385
++ tristate "Vitesse VSC7385 ethernet switch driver"
++ help
++ SPI driver for the Vitesse VSC7385 ethernet switch.
++
+ #
+ # Add new SPI protocol masters in alphabetical order above this line
+ #
+--- a/drivers/spi/Makefile
++++ b/drivers/spi/Makefile
+@@ -40,6 +40,7 @@ obj-$(CONFIG_SPI_STMP3XXX) += spi_stmp.
+
+ # SPI protocol drivers (device/link on bus)
+ obj-$(CONFIG_SPI_SPIDEV) += spidev.o
++obj-$(CONFIG_SPI_VSC7385) += spi_vsc7385.o
+ obj-$(CONFIG_SPI_TLE62X0) += tle62x0.o
+ # ... add above this line ...
+