aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.32/101-ksz8041_phy_driver.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-12-04 20:27:03 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-12-04 20:27:03 +0000
commit34a28b34370830448d744f4bb5dd6905ffd3d9e2 (patch)
treef89dce2f46714984c00d784de052f9292aa8453a /target/linux/ar71xx/patches-2.6.32/101-ksz8041_phy_driver.patch
parentba3154ad3471bfb34b22d856b107348d7200fa9c (diff)
downloadmaster-187ad058-34a28b34370830448d744f4bb5dd6905ffd3d9e2.tar.gz
master-187ad058-34a28b34370830448d744f4bb5dd6905ffd3d9e2.tar.bz2
master-187ad058-34a28b34370830448d744f4bb5dd6905ffd3d9e2.zip
ar71xx: experimental 2.6.32 support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18638 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.32/101-ksz8041_phy_driver.patch')
-rw-r--r--target/linux/ar71xx/patches-2.6.32/101-ksz8041_phy_driver.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-2.6.32/101-ksz8041_phy_driver.patch b/target/linux/ar71xx/patches-2.6.32/101-ksz8041_phy_driver.patch
new file mode 100644
index 0000000000..866b50386a
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.32/101-ksz8041_phy_driver.patch
@@ -0,0 +1,24 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -114,6 +114,11 @@ config RTL8306_PHY
+ tristate "Driver for Realtek RTL8306S switches"
+ select SWCONFIG
+
++config MICREL_PHY
++ tristate "Drivers for Micrel/Kendin PHYs"
++ ---help---
++ Currently has a driver for the KSZ8041
++
+ config FIXED_PHY
+ bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+ depends on PHYLIB=y
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -21,6 +21,7 @@ obj-$(CONFIG_REALTEK_PHY) += realtek.o
+ obj-$(CONFIG_AR8216_PHY) += ar8216.o
+ obj-$(CONFIG_RTL8306_PHY) += rtl8306.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
++obj-$(CONFIG_MICREL) += micrel.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o
+ obj-$(CONFIG_MDIO_GPIO) += mdio-gpio.o