aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.31/202-spi_vsc7385_driver.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-08-24 19:29:50 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-08-24 19:29:50 +0000
commit392c43fc2cb45abc6468b886ad6d4427167efffa (patch)
treef8c70e746cad812e42f615d55e4996343e373b1a /target/linux/ar71xx/patches-2.6.31/202-spi_vsc7385_driver.patch
parentba80b7417b3c32a8570c759476f1fe2029366467 (diff)
downloadmaster-187ad058-392c43fc2cb45abc6468b886ad6d4427167efffa.tar.gz
master-187ad058-392c43fc2cb45abc6468b886ad6d4427167efffa.tar.bz2
master-187ad058-392c43fc2cb45abc6468b886ad6d4427167efffa.zip
[ar71xx] add patches for 2.6.31
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17366 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.31/202-spi_vsc7385_driver.patch')
-rw-r--r--target/linux/ar71xx/patches-2.6.31/202-spi_vsc7385_driver.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-2.6.31/202-spi_vsc7385_driver.patch b/target/linux/ar71xx/patches-2.6.31/202-spi_vsc7385_driver.patch
new file mode 100644
index 0000000000..d8f61bb909
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.31/202-spi_vsc7385_driver.patch
@@ -0,0 +1,24 @@
+--- a/drivers/spi/Kconfig
++++ b/drivers/spi/Kconfig
+@@ -279,6 +279,11 @@ config SPI_TLE62X0
+ sysfs interface, with each line presented as a kind of GPIO
+ exposing both switch control and diagnostic feedback.
+
++config SPI_VSC7385
++ tristate "Vitesse VSC7385 ethernet switch driver"
++ help
++ SPI driver for the Vitesse VSC7385 ethernet switch.
++
+ #
+ # Add new SPI protocol masters in alphabetical order above this line
+ #
+--- a/drivers/spi/Makefile
++++ b/drivers/spi/Makefile
+@@ -38,6 +38,7 @@ obj-$(CONFIG_SPI_SH_SCI) += spi_sh_sci.
+
+ # SPI protocol drivers (device/link on bus)
+ obj-$(CONFIG_SPI_SPIDEV) += spidev.o
++obj-$(CONFIG_SPI_VSC7385) += spi_vsc7385.o
+ obj-$(CONFIG_SPI_TLE62X0) += tle62x0.o
+ # ... add above this line ...
+