aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.30
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-06-04 07:51:29 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-06-04 07:51:29 +0000
commit90183675e405fc7f3728e9c1ba25f6375eea2f02 (patch)
tree6b3e20e12cf2bdc79b3a2f7c954aa03cb74aac7e /target/linux/ar71xx/patches-2.6.30
parent7597eb6ec33933c4468a42c723bce3645f97ec11 (diff)
downloadmaster-187ad058-90183675e405fc7f3728e9c1ba25f6375eea2f02.tar.gz
master-187ad058-90183675e405fc7f3728e9c1ba25f6375eea2f02.tar.bz2
master-187ad058-90183675e405fc7f3728e9c1ba25f6375eea2f02.zip
[ar71xx] add SPI driver for the Vitesse VSC7385 switch
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16324 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.30')
-rw-r--r--target/linux/ar71xx/patches-2.6.30/202-spi_vsc7385_driver.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-2.6.30/202-spi_vsc7385_driver.patch b/target/linux/ar71xx/patches-2.6.30/202-spi_vsc7385_driver.patch
new file mode 100644
index 0000000000..b071d5d21c
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.30/202-spi_vsc7385_driver.patch
@@ -0,0 +1,24 @@
+--- a/drivers/spi/Kconfig
++++ b/drivers/spi/Kconfig
+@@ -272,6 +272,11 @@ config SPI_TLE62X0
+ sysfs interface, with each line presented as a kind of GPIO
+ exposing both switch control and diagnostic feedback.
+
++config SPI_VSC7385
++ tristate "Vitesse VSC7385 ethernet switch driver"
++ help
++ SPI driver for the Vitesse VSC7385 ethernet switch.
++
+ #
+ # Add new SPI protocol masters in alphabetical order above this line
+ #
+--- a/drivers/spi/Makefile
++++ b/drivers/spi/Makefile
+@@ -37,6 +37,7 @@ obj-$(CONFIG_SPI_SH_SCI) += spi_sh_sci.
+
+ # SPI protocol drivers (device/link on bus)
+ obj-$(CONFIG_SPI_SPIDEV) += spidev.o
++obj-$(CONFIG_SPI_VSC7385) += spi_vsc7385.o
+ obj-$(CONFIG_SPI_TLE62X0) += tle62x0.o
+ # ... add above this line ...
+