aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.30
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-07-11 15:55:55 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-07-11 15:55:55 +0000
commit01b93ffd271eacad6458a3aab80bc241a722443e (patch)
treeb7848902a6013560d36d80ff206de6fa8089bb89 /target/linux/ar71xx/patches-2.6.30
parent98a02e113ba9346c08916682ca2ace222c20c7a7 (diff)
downloadmaster-187ad058-01b93ffd271eacad6458a3aab80bc241a722443e.tar.gz
master-187ad058-01b93ffd271eacad6458a3aab80bc241a722443e.tar.bz2
master-187ad058-01b93ffd271eacad6458a3aab80bc241a722443e.zip
[ar71xx] add SPI controller driver for the PB44 board
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16781 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.30')
-rw-r--r--target/linux/ar71xx/patches-2.6.30/203-pb44_spi_controller.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-2.6.30/203-pb44_spi_controller.patch b/target/linux/ar71xx/patches-2.6.30/203-pb44_spi_controller.patch
new file mode 100644
index 0000000000..e48710ca91
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.30/203-pb44_spi_controller.patch
@@ -0,0 +1,27 @@
+--- a/drivers/spi/Kconfig
++++ b/drivers/spi/Kconfig
+@@ -68,6 +68,14 @@ config SPI_AR71XX
+ help
+ This is the SPI contoller driver for Atheros AR71xx.
+
++config SPI_PB44
++ tristate "Atheros PB44 board specific SPI controller"
++ depends on SPI_MASTER && AR71XX_MACH_PB44
++ select SPI_BITBANG
++ help
++ This is a specific SPI controller driver for the Atheros PB44
++ reference board.
++
+ config SPI_ATMEL
+ tristate "Atmel SPI Controller"
+ depends on (ARCH_AT91 || AVR32)
+--- a/drivers/spi/Makefile
++++ b/drivers/spi/Makefile
+@@ -22,6 +22,7 @@ obj-$(CONFIG_SPI_GPIO) += spi_gpio.o
+ obj-$(CONFIG_SPI_GPIO_OLD) += spi_gpio_old.o
+ obj-$(CONFIG_SPI_IMX) += spi_imx.o
+ obj-$(CONFIG_SPI_LM70_LLP) += spi_lm70llp.o
++obj-$(CONFIG_SPI_PB44) += pb44_spi.o
+ obj-$(CONFIG_SPI_PXA2XX) += pxa2xx_spi.o
+ obj-$(CONFIG_SPI_OMAP_UWIRE) += omap_uwire.o
+ obj-$(CONFIG_SPI_OMAP24XX) += omap2_mcspi.o