aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/nand
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-10-23 15:43:26 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-10-23 15:43:26 +0000
commit31639e70b8bbfdf39c9e6caf4f43b0a8d5b30539 (patch)
treeb03a72a3fc3f8108c8ff405604fc1b5a6c22168a /target/linux/ar71xx/nand
parent3080df79e77d509ac76648ee50d362640722a2f0 (diff)
downloadmaster-187ad058-31639e70b8bbfdf39c9e6caf4f43b0a8d5b30539.tar.gz
master-187ad058-31639e70b8bbfdf39c9e6caf4f43b0a8d5b30539.tar.bz2
master-187ad058-31639e70b8bbfdf39c9e6caf4f43b0a8d5b30539.zip
ar71xx: rename 'nand' subtarget to 'mikrotik'
It is for Mikrotik devices only, rename the subtarget to reflect that. Also fix the wget2nand script to use the new image names. Based on the patch by Stefan Agner: http://patchwork.openwrt.org/patch/4123/ Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38509 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/nand')
-rw-r--r--target/linux/ar71xx/nand/config-default34
-rw-r--r--target/linux/ar71xx/nand/profiles/01-minimal.mk16
-rw-r--r--target/linux/ar71xx/nand/profiles/02-ath5k.mk16
-rw-r--r--target/linux/ar71xx/nand/target.mk8
4 files changed, 0 insertions, 74 deletions
diff --git a/target/linux/ar71xx/nand/config-default b/target/linux/ar71xx/nand/config-default
deleted file mode 100644
index efa562c66e..0000000000
--- a/target/linux/ar71xx/nand/config-default
+++ /dev/null
@@ -1,34 +0,0 @@
-CONFIG_ATH79_MACH_RB2011=y
-CONFIG_ATH79_MACH_RB4XX=y
-CONFIG_ATH79_MACH_RB750=y
-CONFIG_ATH79_MACH_RB95X=y
-CONFIG_ATH79_ROUTERBOOT=y
-CONFIG_CMDLINE="rootfstype=yaffs noinitrd"
-# CONFIG_JFFS2_FS is not set
-CONFIG_LEDS_RB750=y
-CONFIG_MDIO_BITBANG=y
-CONFIG_MDIO_GPIO=y
-CONFIG_MTD_NAND=y
-CONFIG_MTD_NAND_AR934X=y
-CONFIG_MTD_NAND_ECC=y
-CONFIG_MTD_NAND_RB4XX=y
-CONFIG_MTD_NAND_RB750=y
-# CONFIG_MTD_SM_COMMON is not set
-# CONFIG_OVERLAYFS_FS is not set
-CONFIG_RLE_DECOMPRESS=y
-CONFIG_SPI_RB4XX=y
-CONFIG_SPI_RB4XX_CPLD=y
-# CONFIG_SQUASHFS is not set
-CONFIG_YAFFS_9BYTE_TAGS=y
-CONFIG_YAFFS_ALWAYS_CHECK_CHUNK_ERASED=y
-CONFIG_YAFFS_AUTO_YAFFS2=y
-# CONFIG_YAFFS_DISABLE_BACKGROUND is not set
-# CONFIG_YAFFS_DISABLE_BLOCK_REFRESHING is not set
-# CONFIG_YAFFS_DISABLE_TAGS_ECC is not set
-# CONFIG_YAFFS_DISABLE_WIDE_TNODES is not set
-# CONFIG_YAFFS_EMPTY_LOST_AND_FOUND is not set
-CONFIG_YAFFS_FS=y
-CONFIG_YAFFS_SHORT_NAMES_IN_RAM=y
-CONFIG_YAFFS_XATTR=y
-CONFIG_YAFFS_YAFFS1=y
-CONFIG_YAFFS_YAFFS2=y
diff --git a/target/linux/ar71xx/nand/profiles/01-minimal.mk b/target/linux/ar71xx/nand/profiles/01-minimal.mk
deleted file mode 100644
index 3651c88ab2..0000000000
--- a/target/linux/ar71xx/nand/profiles/01-minimal.mk
+++ /dev/null
@@ -1,16 +0,0 @@
-#
-# Copyright (C) 2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/DefaultNoWifi
- NAME:=Default Profile (no WiFi)
- PACKAGES:=
-endef
-
-define Profile/DefaultNoWifi/Description
- Default package set compatible with most boards.
-endef
-$(eval $(call Profile,DefaultNoWifi))
diff --git a/target/linux/ar71xx/nand/profiles/02-ath5k.mk b/target/linux/ar71xx/nand/profiles/02-ath5k.mk
deleted file mode 100644
index a291ff68ae..0000000000
--- a/target/linux/ar71xx/nand/profiles/02-ath5k.mk
+++ /dev/null
@@ -1,16 +0,0 @@
-#
-# Copyright (C) 2009-2012 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Ath5k
- NAME:=Atheros WiFi (ath5k)
- PACKAGES:=kmod-ath5k -kmod-ath9k
-endef
-
-define Profile/Ath5k/Description
- Package set compatible with hardware using Atheros WiFi cards.
-endef
-$(eval $(call Profile,Ath5k))
diff --git a/target/linux/ar71xx/nand/target.mk b/target/linux/ar71xx/nand/target.mk
deleted file mode 100644
index 45d2624cd4..0000000000
--- a/target/linux/ar71xx/nand/target.mk
+++ /dev/null
@@ -1,8 +0,0 @@
-BOARDNAME:=Mikrotik devices with NAND flash
-
-define Target/Description
- Build firmware images for Atheros AR71xx/AR913x based Mikrotik boards.
- e.g. MikroTik RB-4xx or RB-750
-endef
-
-