aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/modules.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-06-07 07:22:11 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-06-07 07:22:11 +0000
commitcf601e4c16339cfb7f5ea48f94f84b64fafd8933 (patch)
tree9fe3d56a1309dfd00c55cdfcda2c0b62c08d8e6f /target/linux/ar71xx/modules.mk
parent1319e5d492a1a4be5ba7f5ff78f4c915f061f14e (diff)
downloadmaster-187ad058-cf601e4c16339cfb7f5ea48f94f84b64fafd8933.tar.gz
master-187ad058-cf601e4c16339cfb7f5ea48f94f84b64fafd8933.tar.bz2
master-187ad058-cf601e4c16339cfb7f5ea48f94f84b64fafd8933.zip
kernel: remove NAND flash related kmod-* packages
They are useless, as the platform already selects the right options for NAND support. The main reason for removing them is the fact that it makes kernel configs more annoying to maintain on platforms that provide NAND drivers but disable them (e.g. ramips) Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45919 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/modules.mk')
-rw-r--r--target/linux/ar71xx/modules.mk18
1 files changed, 0 insertions, 18 deletions
diff --git a/target/linux/ar71xx/modules.mk b/target/linux/ar71xx/modules.mk
index 4530708de9..a6a13d2613 100644
--- a/target/linux/ar71xx/modules.mk
+++ b/target/linux/ar71xx/modules.mk
@@ -37,24 +37,6 @@ endef
$(eval $(call KernelPackage,leds-wndr3700-usb))
-define KernelPackage/nand-ar934x
- SUBMENU:=$(OTHER_MENU)
- TITLE:=Atheros AR934x NAND flash controller driver
- KCONFIG:=\
- CONFIG_MTD_NAND_AR934X \
- CONFIG_MTD_NAND_AR934X_HW_ECC=y
- DEPENDS:=@TARGET_ar71xx +kmod-nand
- FILES:=$(LINUX_DIR)/drivers/mtd/nand/ar934x_nfc.ko
- AUTOLOAD:=$(call AutoLoad,25,ar934x_nfc)
-endef
-
-define KernelPackage/nand-ar934x/description
- Atheros AR934x NAND flash controller driver.
-endef
-
-$(eval $(call KernelPackage,nand-ar934x))
-
-
define KernelPackage/spi-vsc7385
SUBMENU:=$(SPI_MENU)
TITLE:=Vitesse VSC7385 ethernet switch driver