aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/modules.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-12-11 15:04:57 +0000
committerJohn Crispin <blogic@openwrt.org>2015-12-11 15:04:57 +0000
commit775ee20c1d2b60f854f605e8846186d13d7ad423 (patch)
tree659ad163c889d0bb3d946120633683434c3e02d5 /target/linux/ar71xx/modules.mk
parent6c8c0504855e51cca630dcb805156ddbf2404356 (diff)
downloadmaster-187ad058-775ee20c1d2b60f854f605e8846186d13d7ad423.tar.gz
master-187ad058-775ee20c1d2b60f854f605e8846186d13d7ad423.tar.bz2
master-187ad058-775ee20c1d2b60f854f605e8846186d13d7ad423.zip
ar71xx: add LED driver NU801
The MR18 uses a 3-channel 16-bit PWM Constant Current Driver for its status LED. Signed-off-by: Chris R Blake <chrisrblake93@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47848 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/modules.mk')
-rw-r--r--target/linux/ar71xx/modules.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/ar71xx/modules.mk b/target/linux/ar71xx/modules.mk
index a6a13d2613..9ead8b451c 100644
--- a/target/linux/ar71xx/modules.mk
+++ b/target/linux/ar71xx/modules.mk
@@ -5,6 +5,22 @@
# See /LICENSE for more information.
#
+define KernelPackage/leds-nu801
+ SUBMENU:=$(LEDS_MENU)
+ TITLE:=Meraki MR18 LED support
+ DEPENDS:=@TARGET_ar71xx
+ KCONFIG:=CONFIG_LEDS_NU801
+ FILES:=$(LINUX_DIR)/drivers/leds/leds-nu801.ko
+ AUTOLOAD:=$(call AutoLoad,60,leds-nu801)
+endef
+
+define KernelPackage/leds-nu801/description
+ Kernel module for the nu801 LED driver used on the Meraki MR18.
+endef
+
+$(eval $(call KernelPackage,leds-nu801))
+
+
define KernelPackage/leds-rb750
SUBMENU:=$(LEDS_MENU)
TITLE:=RouterBOARD 750 LED support