aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2011-04-12 09:29:10 +0000
committerGabor Juhos <juhosg@openwrt.org>2011-04-12 09:29:10 +0000
commitfa7cdb26c4c752fcb09363b7f1c9b15760ca2b6b (patch)
tree0c99c669aa1e4bd20a770e7661c3343f84472323 /target/linux/ar71xx/image
parent6c3889439396446acc26b2ae9dd8ad7426cd1fbe (diff)
downloadmaster-187ad058-fa7cdb26c4c752fcb09363b7f1c9b15760ca2b6b.tar.gz
master-187ad058-fa7cdb26c4c752fcb09363b7f1c9b15760ca2b6b.tar.bz2
master-187ad058-fa7cdb26c4c752fcb09363b7f1c9b15760ca2b6b.zip
ar71xx: Add support for WZR-HP-G301NH
Add support for the Buffalo WZR-HP-G301NH. The only difference between it and the WZR-HP-G00NH is that it has a RTL8366RB instead of a RTL8366S. Since we don't do runtime detection of the switch, we need a separate machine definition for it. While we are at it, also rename the profile to reflect that it now is for more than one device. Signed-off-by: Jonas Gorski <jonas.gorski+openwrt@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26601 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index ca5e280428..e7d2f0efa2 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -118,7 +118,7 @@ define Image/Build/DIR825B1
fi; fi
endef
-define Image/Build/WZRHPG300NH
+define Image/Build/WZRHPG30XNH
$(call PatchKernelLzma,$(2),$(3))
if [ `stat -c%s "$(KDIR)/vmlinux-$(2).bin.lzma"` -gt 1048576 ]; then \
echo "Warning: $(KDIR)/vmlinux-$(2).bin.lzma is too big"; \
@@ -688,8 +688,9 @@ define Image/Build/Profile/WRT160NL
$(call Image/Build/Template/$(fs_64k)/$(1),CyberTAN,wrt160nl,board=WRT160NL,1.00.01)
endef
-define Image/Build/Profile/WZRHPG300NH
- $(call Image/Build/Template/$(fs_128k)/$(1),WZRHPG300NH,wzr-hp-g300nh,board=WZR-HP-G300NH)
+define Image/Build/Profile/WZRHPG30XNH
+ $(call Image/Build/Template/$(fs_128k)/$(1),WZRHPG30XNH,wzr-hp-g300nh,board=WZR-HP-G300NH)
+ $(call Image/Build/Template/$(fs_128k)/$(1),WZRHPG30XNH,wzr-hp-g301nh,board=WZR-HP-G301NH)
endef
define Image/Build/Profile/ZCN1523H28
@@ -740,7 +741,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/AP96,$(1))
$(call Image/Build/Profile/WRT400N,$(1))
$(call Image/Build/Profile/WRT160NL,$(1))
- $(call Image/Build/Profile/WZRHPG300NH,$(1))
+ $(call Image/Build/Profile/WZRHPG30XNH,$(1))
$(call Image/Build/Profile/ZCN1523H28,$(1))
$(call Image/Build/Profile/ZCN1523H516,$(1))
endef