aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-10-30 06:54:55 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-10-30 06:54:55 +0000
commitf1331472ec0241e305bb22a08896c3062d74a860 (patch)
treef004d462092e5f8aeacab20280c5ddfbe9c8a0a2 /target/linux/ar71xx/image
parentfc8781e03ead8efb8fbd5f5578339f252beaf2e5 (diff)
downloadmaster-187ad058-f1331472ec0241e305bb22a08896c3062d74a860.tar.gz
master-187ad058-f1331472ec0241e305bb22a08896c3062d74a860.tar.bz2
master-187ad058-f1331472ec0241e305bb22a08896c3062d74a860.zip
ar71xx: don't build uImages for the mikrotik subtarget
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38598 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 36181e7a47..f2b6befa8e 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -74,6 +74,7 @@ define PatchKernelGzip
gzip -9 -c $(KDIR_TMP)/vmlinux$(3)-$(1) > $(KDIR_TMP)/vmlinux$(3)-$(1).bin.gz
endef
+ifneq ($(SUBTARGET),mikrotik)
define MkuImage
mkimage -A mips -O linux -T kernel -a 0x80060000 -C $(1) $(2) \
-e 0x80060000 -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
@@ -103,6 +104,7 @@ endef
define MkuImageOKLI
$(call MkuImage,lzma,-M 0x4f4b4c49,$(KDIR)/vmlinux.bin.lzma,$(KDIR_TMP)/vmlinux-$(1).okli)
endef
+endif
define CatFiles
if [ $(2) -eq 0 ]; then \