aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-11-01 18:33:24 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-11-01 18:33:24 +0000
commitea7515ccf3cdf0b78e804cfc3f1643ea1ea09c8a (patch)
treea8b687cc0b8d939a0670855ed37a0ce519c3fb36 /target/linux/ar71xx/image
parentebbbf32b07d2c418bb9ba83bf947b5a99b6b4801 (diff)
downloadmaster-187ad058-ea7515ccf3cdf0b78e804cfc3f1643ea1ea09c8a.tar.gz
master-187ad058-ea7515ccf3cdf0b78e804cfc3f1643ea1ea09c8a.tar.bz2
master-187ad058-ea7515ccf3cdf0b78e804cfc3f1643ea1ea09c8a.zip
ar71xx: image: only define profiles for the generic subtarget
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38636 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 316f8bd589..0d8f72b5f6 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -796,6 +796,7 @@ $(eval $(call BuildTemplate,128kraw,-raw,128k))
$(eval $(call BuildTemplate,256k,,256k))
$(eval $(call BuildTemplate,all,,64k 128k 256k))
+ifeq ($(SUBTARGET),generic)
$(eval $(call SingleProfile,ALFA,64k,ALFANX,alfa-nx,ALFA-NX,ttyS0,115200,$$(alfa_mtdlayout_8M),1638400,6291456,vmlinux.gz.uImage,pb9x-2.6.31-jffs2))
$(eval $(call SingleProfile,ALFA,64k,HORNETUB,hornet-ub,HORNET-UB,ttyATH0,115200,$$(alfa_mtdlayout_8M),1638400,6291456,kernel_image,rootfs_image))
@@ -999,9 +1000,11 @@ $(eval $(call MultiProfile,WNDR3700,WNDR3700V1 WNDR3700V2 WNDR3800 WNDRMAC WNDRM
$(eval $(call MultiProfile,WP543,WP543_2M WP543_4M WP543_8M WP543_16M))
$(eval $(call MultiProfile,WPE72,WPE72_4M WPE72_8M WPE72_16M))
-$(eval $(call MultiProfile,Default,$(SINGLE_PROFILES)))
$(eval $(call MultiProfile,Minimal,$(SINGLE_PROFILES)))
$(eval $(call MultiProfile,Madwifi,EAP7660D UBNTRS UBNTRSPRO UBNTLSSR71 WP543))
+endif # ifeq ($(SUBTARGET),generic)
+
+$(eval $(call MultiProfile,Default,$(SINGLE_PROFILES)))
define Image/Build/squashfs
cp $(KDIR)/root.squashfs $(KDIR)/root.squashfs-raw