aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2016-04-26 11:43:45 +0000
committerJohn Crispin <blogic@openwrt.org>2016-04-26 11:43:45 +0000
commitd9ae955c46cdfca5c5a06839b0a963c82787dd5a (patch)
treea0402ec28033509c04e82c263253b084cbceb9a1 /target/linux/ar71xx/image
parentd43b701747d57df4cbfcc1f05a7d6fe5692306a0 (diff)
downloadmaster-187ad058-d9ae955c46cdfca5c5a06839b0a963c82787dd5a.tar.gz
master-187ad058-d9ae955c46cdfca5c5a06839b0a963c82787dd5a.tar.bz2
master-187ad058-d9ae955c46cdfca5c5a06839b0a963c82787dd5a.zip
ar71xx: Add TP-Link TL-WR740N v6 support to trunk
This patch adds support for the TP-Link TL-WR740N v6 into OpenWrt trunk. Hardware wise, it's very similar to the TL-WR841N v10. See the forum thread [1]. Credit goes to the user 'traveler' who did the legwork and tested builds. Also thanks to Matthias Schiffer for clarifying the DEVICE_PROFILE settings. Signed-off by: Stijn Segers <francesco.borromini@inventati.org> [1]: https://forum.openwrt.org/viewtopic.php?pid=318704 git-svn-id: svn://svn.openwrt.org/openwrt/trunk@49245 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 2b2e868822..85966db12a 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -755,6 +755,13 @@ define Device/tl-wr740n-v5
CONSOLE := ttyATH0,115200
endef
+define Device/tl-wr740n-v6
+ $(Device/tplink-4mlzma)
+ BOARDNAME := TL-WR841N-v9
+ DEVICE_PROFILE := TLWR740
+ TPLINK_HWID := 0x07400006
+endef
+
define Device/tl-wr741nd-v1
$(Device/tplink-4m)
BOARDNAME := TL-WR741ND
@@ -799,7 +806,7 @@ define Device/tl-wr743nd-v2
TPLINK_HWID := 0x07430002
CONSOLE := ttyATH0,115200
endef
-TARGET_DEVICES += tl-wr740n-v1 tl-wr740n-v3 tl-wr740n-v4 tl-wr740n-v5 tl-wr741nd-v1 tl-wr741nd-v2 tl-wr741nd-v4 tl-wr741nd-v5 tl-wr743nd-v1 tl-wr743nd-v2
+TARGET_DEVICES += tl-wr740n-v1 tl-wr740n-v3 tl-wr740n-v4 tl-wr740n-v5 tl-wr740n-v6 tl-wr741nd-v1 tl-wr741nd-v2 tl-wr741nd-v4 tl-wr741nd-v5 tl-wr743nd-v1 tl-wr743nd-v2
define Device/tl-wr841-v1.5
$(Device/tplink-4m)