aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-08-23 12:04:57 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-08-23 12:04:57 +0000
commitd6190769d0ed3ebe3ab0a2ff44edadddb5c5ebef (patch)
treeaffeb0af7f3841f89be352b408edf0bc5f7be8bb /target/linux/ar71xx/image
parent9b8d64254e772dbcfbd28e738719979315055914 (diff)
downloadmaster-187ad058-d6190769d0ed3ebe3ab0a2ff44edadddb5c5ebef.tar.gz
master-187ad058-d6190769d0ed3ebe3ab0a2ff44edadddb5c5ebef.tar.bz2
master-187ad058-d6190769d0ed3ebe3ab0a2ff44edadddb5c5ebef.zip
ar71xx: image: use the new helpers for the Cameo7240 images
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33241 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/Makefile22
1 files changed, 4 insertions, 18 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index ed7ce2cf7f..c9ec358b68 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -754,20 +754,9 @@ define Image/Build/Profile/WPE72
$(call Image/Build/Template/$(fs_64k)/$(1),MyLoader,wpe72,$(wpe72_cmdline),0x800000,8M)
endef
-dir600a1_cmdline=board=DIR-600-A1 console=ttyS0,115200
-define Image/Build/Profile/DIR600A1
- $(call Image/Build/Template/$(fs_64k)/$(1),Cameo7240,dir-600-a1,$(dir600a1_cmdline),"AP91-AR7240-RT-090223-00")
-endef
-
-dir601a1_cmdline=board=DIR-600-A1 console=ttyS0,115200
-define Image/Build/Profile/DIR601A1
- $(call Image/Build/Template/$(fs_64k)/$(1),Cameo7240,dir-601-a1,$(dir600a1_cmdline),"AP91-AR7240-RT-090223-02")
-endef
-
-dir615e4_cmdline=board=DIR-615-E4 console=ttyS0,115200
-define Image/Build/Profile/DIR615E4
- $(call Image/Build/Template/$(fs_64k)/$(1),Cameo7240,dir-615-e4,$(dir615e4_cmdline),"AP99-AR7240-RT-091105-05")
-endef
+$(eval $(call SingleProfile,Cameo7240,$(fs_64k),DIR600A1,dir-600-a1,DIR-600-A1,ttyS0,115200,"AP91-AR7240-RT-090223-00"))
+$(eval $(call SingleProfile,Cameo7240,$(fs_64k),DIR601A1,dir-601-a1,DIR-600-A1,ttyS0,115200,"AP91-AR7240-RT-090223-02"))
+$(eval $(call SingleProfile,Cameo7240,$(fs_64k),DIR615E4,dir-615-e4,DIR-615-E4,ttyS0,115200,"AP99-AR7240-RT-091105-05"))
eap7660d_cmdline=board=EAP7660D console=ttyS0,115200
define Image/Build/Profile/EAP7660D
@@ -791,10 +780,7 @@ define Image/Build/Profile/JWAP003
$(call Image/Build/Template/$(fs_64k)/$(1),PB4X,jwap003,$(jwap003_cmdline))
endef
-fr54rtr_cmdline=board=DIR-600-A1 console=ttyS0,115200
-define Image/Build/Profile/FR54RTR
- $(call Image/Build/Template/$(fs_64k)/$(1),Cameo7240,fr-54rtr,$(fr54rtr_cmdline),"AP91-AR7240-RT-090223-01")
-endef
+$(eval $(call SingleProfile,Cameo7240,$(fs_64k),FR54RTR,fr-54rtr,DIR-600-A1,ttyS0,115200,"AP91-AR7240-RT-090223-01"))
dir615c1_cmdline=board=DIR-615-C1 console=ttyS0,115200
define Image/Build/Profile/DIR615C1