aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2009-12-19 14:45:43 +0000
committerNicolas Thill <nico@openwrt.org>2009-12-19 14:45:43 +0000
commitc97b8e0db1299c7679493ee9db26c1f21376f70a (patch)
tree2ca97cf2e9b991d4f7bbfa15d8c174483da22948 /target/linux/ar71xx/image
parent8d124c9f49af80e4a72f67ce377fba62940d04a5 (diff)
downloadmaster-187ad058-c97b8e0db1299c7679493ee9db26c1f21376f70a.tar.gz
master-187ad058-c97b8e0db1299c7679493ee9db26c1f21376f70a.tar.bz2
master-187ad058-c97b8e0db1299c7679493ee9db26c1f21376f70a.zip
[target] ar71xx: fix WNDR3700 image generation
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18849 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 051f0a3f29..92f698a35c 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -237,14 +237,13 @@ wndr3700_mtdlayout=mtdparts=spi0.0:320k(u-boot)ro,128k(u-boot-env)ro,1024k(kerne
define Image/Build/WNDR3700
$(call PatchKernelLzma,$(2),$(3) $(wndr3700_mtdlayout))
$(call MkImageLzma,$(KDIR)/vmlinux-$(2).bin.lzma,$(KDIR)/vmlinux-$(2).uImage)
- mkdir $(KDIR)/wndr3700
- mkdir $(KDIR)/wndr3700/image
+ mkdir -p $(KDIR)/wndr3700/image
$(STAGING_DIR_HOST)/bin/wndr3700 \
$(KDIR)/vmlinux-$(2).uImage \
$(KDIR)/wndr3700/image/uImage
- $(STAGING_DIR_HOST)/bin/mksquashfs-lzma \
+ $(MKSQUASHFS_CMD) \
$(KDIR)/wndr3700 $(KDIR)/vmlinux-$(2).uImage.squashfs.tmp \
- -nopad -noappend -root-owned -be
+ -nopad -noappend -root-owned $(SQUASHFS_OPTS)
-rm -rf $(KDIR)/wndr3700
mkimage -A mips -O linux -T filesystem -C none \
-a 0xbf070000 -e 0xbf070000 \