aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2013-07-10 17:18:03 +0000
committerFlorian Fainelli <florian@openwrt.org>2013-07-10 17:18:03 +0000
commitc7ae72df76848f1b5be2410d30cd322f18b6991f (patch)
treed94220552053c93c4c54ac06969150f964455a3c /target/linux/ar71xx/image
parent7c91723762a48270bd9960b7f7ffabbfac8e9525 (diff)
downloadmaster-187ad058-c7ae72df76848f1b5be2410d30cd322f18b6991f.tar.gz
master-187ad058-c7ae72df76848f1b5be2410d30cd322f18b6991f.tar.bz2
master-187ad058-c7ae72df76848f1b5be2410d30cd322f18b6991f.zip
ar71xx: fix Netgear initramfs images
Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37230 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index e2b0ae3029..1a1b950fec 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -82,8 +82,8 @@ define MkuImage
endef
define MkuImageLzma
- $(call PatchKernelLzma,$(1),$(2),$(3))
- $(call MkuImage,lzma,,$(KDIR_TMP)/vmlinux-$(1).bin.lzma,$(KDIR_TMP)/vmlinux-$(1).uImage)
+ $(call PatchKernelLzma,$(1),$(2),$(3),$(4))
+ $(call MkuImage,lzma,,$(KDIR_TMP)/vmlinux$(4)-$(1).bin.lzma,$(KDIR_TMP)/vmlinux$(4)-$(1).uImage)
endef
define MkuImageLzma/initramfs
@@ -701,7 +701,7 @@ define Image/Build/Netgear
endef
define Image/Build/Netgear/initramfs
- $(call MkuImageLzma,$(2),$(3) $(4))
+ $(call MkuImageLzma,$(2),$(3) $(4),,-initramfs)
$(STAGING_DIR_HOST)/bin/wndr3700 \
$(KDIR_TMP)/vmlinux-initramfs-$(2).uImage \
$(call imgname,$(1),$(2))-initramfs-uImage.bin \