aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-31 23:29:41 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-31 23:29:41 +0000
commitc23de752bc511c937d1eabc222378b554f6ecdd0 (patch)
tree07de2896816d68f1fcb0a786b5faa55f33c6ad91 /target/linux/ar71xx/image
parent0550a6132850009bc12689ccd4c95f170bd9a457 (diff)
downloadmaster-187ad058-c23de752bc511c937d1eabc222378b554f6ecdd0.tar.gz
master-187ad058-c23de752bc511c937d1eabc222378b554f6ecdd0.tar.bz2
master-187ad058-c23de752bc511c937d1eabc222378b554f6ecdd0.zip
ar71xx/image: use SOURCE_DATE_EPOCH for mksquashfs-lzma
Signed-off-by: Alexander Couzens <lynxis@fe80.eu> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48589 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 080d9606a2..5768cbd97b 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -22,7 +22,9 @@ define Build/netgear-squashfs
cp $@ $@.fs/image/uImage
$(STAGING_DIR_HOST)/bin/mksquashfs-lzma \
$@.fs $@.squashfs \
- -noappend -root-owned -be -b 65536
+ -noappend -root-owned -be -b 65536 \
+ $(if $(SOURCE_DATE_EPOCH),-fixed-time $(SOURCE_DATE_EPOCH))
+
dd if=/dev/zero bs=1k count=1 >> $@.squashfs
mkimage \
-A mips -O linux -T filesystem -C none \
@@ -2064,7 +2066,8 @@ define Image/Build/Netgear/buildkernel
cat $(KDIR_TMP)/vmlinux-$(2).uImage > $(KDIR_TMP)/$(2)/image/uImage
$(STAGING_DIR_HOST)/bin/mksquashfs-lzma \
$(KDIR_TMP)/$(2) $(KDIR_TMP)/vmlinux-$(2).uImage.squashfs.tmp1 \
- -noappend -root-owned -be -b 65536
+ -noappend -root-owned -be -b 65536 \
+ $(if $(SOURCE_DATE_EPOCH),-fixed-time $(SOURCE_DATE_EPOCH))
( \
cat $(KDIR_TMP)/vmlinux-$(2).uImage.squashfs.tmp1; \
dd if=/dev/zero bs=1k count=1 \