aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorAllan Nick Pedrana <nik9993@gmail.com>2016-06-22 14:22:05 +0200
committerZoltan HERPAI <wigyori@uid0.hu>2016-06-22 14:22:05 +0200
commitbebdc8766a78b738039c4137e7315560cf0d52a6 (patch)
treee1fa6083bbb30e3662a65ca1fe69b22096a3959d /target/linux/ar71xx/image
parent1d3853d41f0f9971acb32a9e4ef29e97c4cdacc3 (diff)
downloadmaster-187ad058-bebdc8766a78b738039c4137e7315560cf0d52a6.tar.gz
master-187ad058-bebdc8766a78b738039c4137e7315560cf0d52a6.tar.bz2
master-187ad058-bebdc8766a78b738039c4137e7315560cf0d52a6.zip
ar71xx: add support for OpenEmbed SOM9331
This patch adds the target profile SOM9331 and configures hardware functionality for the 3x Eth Ports & corresponding LED's, the USB Host, the USART to USB bridge and the System LED. Signed-off-by: Allan Nick Pedrana <nik9993@gmail.com>
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/generic.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index 012136267a..ca79f98c97 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -271,6 +271,15 @@ define Device/smart-300
endef
TARGET_DEVICES += smart-300
+define Device/som9331
+ $(Device/tplink-8mlzma)
+ BOARDNAME := SOM9331
+ DEVICE_PROFILE := SOM9331
+ TPLINK_HWID := 0x04800054
+ CONSOLE := ttyATH0,115200
+endef
+TARGET_DEVICES += som9331
+
define Device/tellstick-znet-lite
$(Device/tplink-16mlzma)
BOARDNAME := TELLSTICK-ZNET-LITE