aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2016-01-01 21:21:13 +0000
committerJohn Crispin <blogic@openwrt.org>2016-01-01 21:21:13 +0000
commit9b0602dd3afe5e03cd6284ee39d54f8238fd64be (patch)
tree75539893347c0523c86e60618fc1f9d0d6457fdc /target/linux/ar71xx/image
parentaa826858305e1797546d3a50c94905be24a55c31 (diff)
downloadmaster-187ad058-9b0602dd3afe5e03cd6284ee39d54f8238fd64be.tar.gz
master-187ad058-9b0602dd3afe5e03cd6284ee39d54f8238fd64be.tar.bz2
master-187ad058-9b0602dd3afe5e03cd6284ee39d54f8238fd64be.zip
V2 ar71xx : Add Support for the Bitmain Antrouter R1
This patch adds support for the Bitmain Antrouter R1 http://wiki.openwrt.org/toh/bitmain/r1 Signed-off-by: L. D. Pinney <ldpinney@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48058 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index d214eaefef..dd685526e3 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -461,6 +461,14 @@ define Device/antminer-s3
CONSOLE := ttyATH0,115200
endef
+define Device/antrouter-r1
+ $(Device/tplink-8mlzma)
+ BOARDNAME := ANTROUTER-R1
+ DEVICE_PROFILE := ANTROUTERR1
+ TPLINK_HWID := 0x44440101
+ CONSOLE := ttyATH0,115200
+endef
+
define Device/el-m150
$(Device/tplink-8mlzma)
BOARDNAME := EL-M150
@@ -476,7 +484,7 @@ define Device/el-mini
TPLINK_HWID := 0x01530001
CONSOLE := ttyATH0,115200
endef
-TARGET_DEVICES += antminer-s1 antminer-s3 el-m150 el-mini
+TARGET_DEVICES += antminer-s1 antminer-s3 antrouter-r1 el-m150 el-mini
define Device/gl-inet-6408A-v1
$(Device/tplink-8mlzma)