aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-11-14 19:04:48 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-11-14 19:04:48 +0000
commit945d0a1a12d743ecbfd1e02a8d4e1a7f2eba6162 (patch)
treed090fbb8ceb3d2d8581c7da280d849226c86a18f /target/linux/ar71xx/image
parent559e45026b84273e17da408e0fbe468e1f6ac5ea (diff)
downloadmaster-187ad058-945d0a1a12d743ecbfd1e02a8d4e1a7f2eba6162.tar.gz
master-187ad058-945d0a1a12d743ecbfd1e02a8d4e1a7f2eba6162.tar.bz2
master-187ad058-945d0a1a12d743ecbfd1e02a8d4e1a7f2eba6162.zip
ar71xx: use the new padjffs2 padding on Ubiquiti UAP-PRO to make the boot loader stop searching after the kernel partition
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38805 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 3af8375a8c..d1e91c0aa1 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -448,7 +448,7 @@ define Image/Build/UAPPRO/buildkernel
-d $(KDIR_TMP)/$(2)/image \
2>&1 1>/dev/null | awk '/^.+$$$$/'
-rm -rf $(KDIR_TMP)/$(2)
- $(STAGING_DIR_HOST)/bin/padjffs2 $(KDIR_TMP)/$(2)-kernel.jffs2 64
+ $(STAGING_DIR_HOST)/bin/padjffs2 $(KDIR_TMP)/$(2)-kernel.jffs2 -J 64
endef
define Image/Build/UAPPRO