aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2016-04-09 10:26:46 +0000
committerJohn Crispin <blogic@openwrt.org>2016-04-09 10:26:46 +0000
commit86c3263e9d9a735b9e9dce902cb0016dbb9630ec (patch)
tree121c2f171275482d8e657453d67e228a6065d35b /target/linux/ar71xx/image
parent0f029add70e988daa606910c902c0d379a0b7c7d (diff)
downloadmaster-187ad058-86c3263e9d9a735b9e9dce902cb0016dbb9630ec.tar.gz
master-187ad058-86c3263e9d9a735b9e9dce902cb0016dbb9630ec.tar.bz2
master-187ad058-86c3263e9d9a735b9e9dce902cb0016dbb9630ec.zip
ar71xx: add TP-Link TL-WA901ND-v4 support
Signed-off-by: Tiziano Bacocco <tizbac2@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@49158 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index cacdd50bac..e4e2fcf441 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -1087,7 +1087,15 @@ define Device/tl-wa901nd-v3
DEVICE_PROFILE := TLWA901
TPLINK_HWID := 0x09010003
endef
-TARGET_DEVICES += tl-wa901nd-v1 tl-wa901nd-v2 tl-wa901nd-v3
+
+define Device/tl-wa901nd-v4
+ $(Device/tplink-4mlzma)
+ BOARDNAME := TL-WA901ND-v4
+ DEVICE_PROFILE := TLWA901
+ TPLINK_HWID := 0x09010004
+endef
+
+TARGET_DEVICES += tl-wa901nd-v1 tl-wa901nd-v2 tl-wa901nd-v3 tl-wa901nd-v4
define Device/tl-wa7210n-v2
$(Device/tplink-4mlzma)