aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorP.Wassi <p.wassi at gmx.at>2016-06-20 16:54:16 +0200
committerZoltan HERPAI <wigyori@uid0.hu>2016-06-20 16:54:16 +0200
commit58d97c77333bb043c9e718f5f30c9b7712e76472 (patch)
tree791c81dc51adcedac2618641a851225d3476be96 /target/linux/ar71xx/image
parent49ffc6be5bd462ad8e213fec33951b34cb564d32 (diff)
downloadmaster-187ad058-58d97c77333bb043c9e718f5f30c9b7712e76472.tar.gz
master-187ad058-58d97c77333bb043c9e718f5f30c9b7712e76472.tar.bz2
master-187ad058-58d97c77333bb043c9e718f5f30c9b7712e76472.zip
ar71xx: Rename unifiac to unifiac-lite
To avoid confusion with different unifiac devices, rename existing target "unifiac" to "unifiac-lite", before "unifiac-pro" is introduced. Signed-off-by: P.Wassi <p.wassi at gmx.at>
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/Makefile21
1 files changed, 13 insertions, 8 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 94fb4d77ad..87df795425 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -1202,6 +1202,14 @@ define Device/ubnt-bz
IMAGE/sysupgrade.bin = append-kernel $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
endef
+define Device/ubnt-unifiac
+ DEVICE_PROFILE := UBNT
+ IMAGE_SIZE := 7744k
+ MTDPARTS = spi0.0:384k(u-boot)ro,64k(u-boot-env)ro,7744k(firmware),7744k(ubnt-airos)ro,128k(bs)ro,256k(cfg)ro,64k(EEPROM)ro
+ IMAGES := sysupgrade.bin
+ IMAGE/sysupgrade.bin = append-kernel $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
+endef
+
define Device/rw2458n
$(Device/ubnt-xm)
BOARDNAME := RW2458N
@@ -1234,13 +1242,10 @@ define Device/ubnt-unifi
DEVICE_PROFILE := UBNT UBNTUNIFI
endef
-define Device/ubnt-unifiac
- DEVICE_PROFILE := UBNT UBNTUNIFIAC
- IMAGE_SIZE := 7744k
- MTDPARTS = spi0.0:384k(u-boot)ro,64k(u-boot-env)ro,7744k(firmware),7744k(ubnt-airos)ro,128k(bs)ro,256k(cfg)ro,64k(EEPROM)ro
- IMAGES := sysupgrade.bin
- IMAGE/sysupgrade.bin = append-kernel $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
- BOARDNAME := UBNT-UF-AC
+define Device/ubnt-unifiac-lite
+ $(Device/ubnt-unifiac)
+ DEVICE_PROFILE := UBNT UBNTUNIFIACLITE
+ BOARDNAME := UBNT-UF-AC-LITE
endef
define Device/ubnt-unifi-outdoor
@@ -1248,7 +1253,7 @@ define Device/ubnt-unifi-outdoor
BOARDNAME := UBNT-U20
DEVICE_PROFILE := UBNT UBNTUNIFIOUTDOOR
endef
-TARGET_DEVICES += ubnt-unifi ubnt-unifiac ubnt-unifi-outdoor
+TARGET_DEVICES += ubnt-unifi ubnt-unifiac-lite ubnt-unifi-outdoor
define Device/ubnt-nano-m-xw
$(Device/ubnt-xw)