aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-12-19 11:27:45 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-12-19 11:27:45 +0000
commit4414a0da83877902e200dc84b76c21b7c6c6f8f5 (patch)
treeb1bcef3c4cd1068ffe59ce9cb662aa54d2d142ae /target/linux/ar71xx/image
parent49701c6dadf1558cf85f702c8baf0d15d8623405 (diff)
downloadmaster-187ad058-4414a0da83877902e200dc84b76c21b7c6c6f8f5.tar.gz
master-187ad058-4414a0da83877902e200dc84b76c21b7c6c6f8f5.tar.bz2
master-187ad058-4414a0da83877902e200dc84b76c21b7c6c6f8f5.zip
ar71xx: Image generation for PowerCloud CR3000 Cloud Router
Image generation part of support for PowerCloud CR3000. The CR3000 is a 802.11n 2.4 GHz wireless router with 8MB flash, 64MB RAM, a four port fast ethernet switch, and a fast ethernet wan port which was sold by PowerCloud Systems as hardware for the Skydog cloud-managed router service. Signed-off-by: Daniel Dickinson <openwrt@daniel.thecshore.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47942 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/Makefile20
1 files changed, 18 insertions, 2 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 5783221b1d..af9516eaa7 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -212,7 +212,6 @@ define Device/gl-domino
endef
TARGET_DEVICES += gl-domino
-
define Device/wndr3700
BOARDNAME = WNDR3700
NETGEAR_KERNEL_MAGIC = 0x33373030
@@ -410,6 +409,24 @@ endef
TARGET_DEVICES += cap324-nocloud
+define Device/cr3000
+ BOARDNAME := CR3000
+ DEVICE_PROFILE := CR3000
+ IMAGE_SIZE = 7104k
+ MTDPARTS = spi0.0:256k(u-boot),64k(u-boot-env)ro,7104k(firmware),640k(certs),64k(nvram),64k(art)
+endef
+
+TARGET_DEVICES += cr3000
+
+define Device/cr3000-nocloud
+ BOARDNAME := CR3000
+ DEVICE_PROFILE := CR3000
+ IMAGE_SIZE = 7808k
+ MTDPARTS = spi0.0:256k(u-boot),64k(u-boot-env)ro,7808k(firmware),64k(art)
+endef
+
+TARGET_DEVICES += cr3000-nocloud
+
define Device/antminer-s1
$(Device/tplink-8mlzma)
BOARDNAME := ANTMINER-S1
@@ -1470,7 +1487,6 @@ define Build/Clean
$(LOADER_MAKE) clean
endef
-
alfa_ap96_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,256k(u-boot-env)ro,13312k(rootfs),2048k(kernel),512k(caldata)ro,15360k@0x80000(firmware)
alfa_mtdlayout_8M=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,6144k(rootfs),1600k(kernel),64k(nvram),64k(art)ro,7744k@0x50000(firmware)
alfa_mtdlayout_16M=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,15936k(firmware),64k(nvram),64k(art)ro