aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2011-05-31 22:53:18 +0000
committerGabor Juhos <juhosg@openwrt.org>2011-05-31 22:53:18 +0000
commit208eb6ab2e1c0258298dec5caac7a15afdb469ee (patch)
tree5a396e8550a1f6609b48a73f4a58ccc710acfce6 /target/linux/ar71xx/image
parent5d67de1cfde804fca01c07f4518e4a343c3d1cc9 (diff)
downloadmaster-187ad058-208eb6ab2e1c0258298dec5caac7a15afdb469ee.tar.gz
master-187ad058-208eb6ab2e1c0258298dec5caac7a15afdb469ee.tar.bz2
master-187ad058-208eb6ab2e1c0258298dec5caac7a15afdb469ee.zip
ar71xx: reduce the size of the squashfs-4k binaries
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27047 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 3623a6268c..7ff7589d84 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -808,12 +808,11 @@ define Image/Build/Profile/Madwifi
endef
define Image/Build/squashfs
- $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
dd if=$(KDIR)/root.squashfs of=$(KDIR)/root.squashfs-4k.tmp0 bs=4k conv=sync
$(call add_jffs2_mark,$(KDIR)/root.squashfs-4k.tmp0)
dd if=$(KDIR)/root.squashfs-4k.tmp0 of=$(BIN_DIR)/$(IMG_PREFIX)-root.squashfs-4k bs=4k conv=sync
- $(call add_jffs2_mark,$(BIN_DIR)/$(IMG_PREFIX)-root.squashfs-4k)
rm -f $(KDIR)/root.squashfs-4k.tmp0
+ $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
endef
define Image/Build/Initramfs