aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/lzma-loader
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2015-09-12 18:57:37 +0000
committerHauke Mehrtens <hauke@openwrt.org>2015-09-12 18:57:37 +0000
commit034ea61e588a2ac98dd62fba59a537c1164da11a (patch)
tree55fbb9426a281945c3588530fc3ae3f53bc10ef9 /target/linux/ar71xx/image/lzma-loader
parentf523386d0d98ef07c1caf8a41f7c0f838bdd5340 (diff)
downloadmaster-187ad058-034ea61e588a2ac98dd62fba59a537c1164da11a.tar.gz
master-187ad058-034ea61e588a2ac98dd62fba59a537c1164da11a.tar.bz2
master-187ad058-034ea61e588a2ac98dd62fba59a537c1164da11a.zip
ar71xx: fix build of lzma-loader with binutils 2.25.1
To make the lzma-loader build with binutils 2.25.1 it is needed to remove the .MIPS.abiflags section otherwise I get the following compile error: mips-openwrt-linux-musl-objcopy -O binary -R .reginfo -R .note -R .comment -R .mdebug -S loader loader.bin mips-openwrt-linux-musl-objcopy: Warning: Writing section `.text' to huge (ie negative) file offset 0xffffffff80a00000. mips-openwrt-linux-musl-objcopy:loader.bin[.text]: File truncated This should close #20487. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46893 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/image/lzma-loader')
-rw-r--r--target/linux/ar71xx/image/lzma-loader/src/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/lzma-loader/src/Makefile b/target/linux/ar71xx/image/lzma-loader/src/Makefile
index 8038b2fba9..5f10bdb8f1 100644
--- a/target/linux/ar71xx/image/lzma-loader/src/Makefile
+++ b/target/linux/ar71xx/image/lzma-loader/src/Makefile
@@ -27,7 +27,8 @@ LD := $(CROSS_COMPILE)ld
OBJCOPY := $(CROSS_COMPILE)objcopy
OBJDUMP := $(CROSS_COMPILE)objdump
-BIN_FLAGS := -O binary -R .reginfo -R .note -R .comment -R .mdebug -S
+BIN_FLAGS := -O binary -R .reginfo -R .note -R .comment -R .mdebug \
+ -R .MIPS.abiflags -S
CFLAGS = -D__KERNEL__ -Wall -Wstrict-prototypes -Wno-trigraphs -Os \
-fno-strict-aliasing -fno-common -fomit-frame-pointer -G 0 \