aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/legacy.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-06-22 14:19:48 +0200
committerZoltan HERPAI <wigyori@uid0.hu>2016-06-22 14:19:48 +0200
commit1d3853d41f0f9971acb32a9e4ef29e97c4cdacc3 (patch)
tree57a930a837429adc017503a0699b84ebb3235c2c /target/linux/ar71xx/image/legacy.mk
parent4d67ebf8c5d9e740a20bfa3b42ae45898e203a48 (diff)
downloadmaster-187ad058-1d3853d41f0f9971acb32a9e4ef29e97c4cdacc3.tar.gz
master-187ad058-1d3853d41f0f9971acb32a9e4ef29e97c4cdacc3.tar.bz2
master-187ad058-1d3853d41f0f9971acb32a9e4ef29e97c4cdacc3.zip
ar71xx: convert OM2P to device profile
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/ar71xx/image/legacy.mk')
-rw-r--r--target/linux/ar71xx/image/legacy.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/legacy.mk b/target/linux/ar71xx/image/legacy.mk
index a6f1bd4fd7..12e2f55463 100644
--- a/target/linux/ar71xx/image/legacy.mk
+++ b/target/linux/ar71xx/image/legacy.mk
@@ -1164,6 +1164,12 @@ $(eval $(call MultiProfile,Yun,YUN_16M YUN_8M))
$(eval $(call MultiProfile,Minimal,$(SINGLE_PROFILES)))
$(eval $(call MultiProfile,Madwifi,EAP7660D WP543))
+define LegacyDevice/OM2P
+ DEVICE_TITLE := OpenMesh OM2P/OM2Pv2/OM2P-HS/OM2P-HSv2/OM2P-HSv3/OM2P-LC
+ DEVICE_PACKAGES := kmod-ath9k om-watchdog
+endef
+LEGACY_DEVICES += OM2P
+
endif # ifeq ($(SUBTARGET),generic)
ifeq ($(SUBTARGET),nand)
@@ -1209,6 +1215,15 @@ endif
$(call Image/Build/Profile/$(if $(CONFIG_IB),Default,$(IMAGE_PROFILE)),loader)
endef
+define Image/Prepare/Profile
+ $(call Image/Build/Profile/$(1),loader)
+endef
+
+define Image/Build/Profile
+ $(call Image/Build/Profile/$(1),buildkernel)
+ $(call Image/Build/Profile/$(1),$(2))
+endef
+
# $(1): filesystem type.
define Image/Build
$(call Image/Build/$(call rootfs_type,$(1)),$(1))