aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/generic.mk
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2016-06-24 14:00:30 +0200
committerZoltan HERPAI <wigyori@uid0.hu>2016-06-24 14:00:30 +0200
commit5f838bf1f8dd5a145e393a173eecdcccbeecba0e (patch)
tree8ab76057028b24aaad616ab24597e723d5d0f041 /target/linux/ar71xx/image/generic.mk
parentdafbd7fdb872572911269dcec85e736d4c3723d0 (diff)
downloadmaster-187ad058-5f838bf1f8dd5a145e393a173eecdcccbeecba0e.tar.gz
master-187ad058-5f838bf1f8dd5a145e393a173eecdcccbeecba0e.tar.bz2
master-187ad058-5f838bf1f8dd5a145e393a173eecdcccbeecba0e.zip
ar71xx: hiwifi-hc6361: lift size limit on kernel and rootfs parts
The patch has been run-tested and the relevant dmsg logs are as the following [ 0.762447] Creating 5 MTD partitions on "spi0.0": [ 0.767217] 0x000000000000-0x000000010000 : "u-boot" [ 0.775139] 0x000000010000-0x000000020000 : "bdinfo" [ 0.781014] 0x000000020000-0x000000fe0000 : "firmware" [ 0.810558] 2 uimage-fw partitions found on MTD device firmware [ 0.815043] 0x000000020000-0x000000170000 : "kernel" [ 0.821925] 0x000000170000-0x000000fe0000 : "rootfs" [ 0.827587] mtd: device 4 (rootfs) set to be root filesystem [ 0.831937] 1 squashfs-split partitions found on MTD device rootfs [ 0.837983] 0x0000005c0000-0x000000fe0000 : "rootfs_data" [ 0.845621] 0x000000fe0000-0x000000ff0000 : "backup" [ 0.851445] 0x000000ff0000-0x000001000000 : "art" While at it, convert to new build method Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'target/linux/ar71xx/image/generic.mk')
-rw-r--r--target/linux/ar71xx/image/generic.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index ca79f98c97..996bc5b1ac 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -342,3 +342,23 @@ define Device/c-55
endef
TARGET_DEVICES += c-55
+
+
+define Build/uImageHiWiFi
+ # Field ih_name needs to start with "tw150v1"
+ mkimage -A $(LINUX_KARCH) \
+ -O linux -T kernel \
+ -C $(1) -a $(KERNEL_LOADADDR) -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
+ -n 'tw150v1 $(call toupper,$(LINUX_KARCH)) LEDE Linux-$(LINUX_VERSION)' -d $@ $@.new
+ @mv $@.new $@
+endef
+
+define Device/hiwifi-hc6361
+ BOARDNAME := HiWiFi-HC6361
+ DEVICE_PROFILE := HIWIFI_HC6361
+ IMAGE_SIZE := 16128k
+ KERNEL := kernel-bin | patch-cmdline | lzma | uImageHiWiFi lzma
+ CONSOLE := ttyATH0,115200
+ MTDPARTS := spi0.0:64k(u-boot)ro,64k(bdinfo)ro,16128k(firmware),64k(backup)ro,64k(art)ro
+endef
+TARGET_DEVICES += hiwifi-hc6361