aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-07-07 13:46:54 +0000
committerJohn Crispin <blogic@openwrt.org>2015-07-07 13:46:54 +0000
commitef215c0518cec9db3801fc0c0d5aa859e500bb2f (patch)
tree77747dbbf6db6a66410777a47d58c7b1c2a89494 /target/linux/ar71xx/image/Makefile
parentd0b7d64c9dbe6ae3c42696470e60d7cf7baa78db (diff)
downloadmaster-187ad058-ef215c0518cec9db3801fc0c0d5aa859e500bb2f.tar.gz
master-187ad058-ef215c0518cec9db3801fc0c0d5aa859e500bb2f.tar.bz2
master-187ad058-ef215c0518cec9db3801fc0c0d5aa859e500bb2f.zip
ar71xx: Add Support for the Bitmain Antminer S3
This patch adds support for the Bitmain Antminer S3 Cryptocurrency Miner http://wiki.openwrt.org/toh/bitmain/s3 Signed-off-by: L. D. Pinney <ldpinney@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46236 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/image/Makefile')
-rw-r--r--target/linux/ar71xx/image/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 3c052424bd..018385dabf 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -338,6 +338,14 @@ define Device/antminer-s1
CONSOLE := ttyATH0,115200
endef
+define Device/antminer-s3
+ $(Device/tplink-8mlzma)
+ BOARDNAME := ANTMINER-S3
+ DEVICE_PROFILE := ANTMINER_S3
+ TPLINK_HWID := 0x04440003
+ CONSOLE := ttyATH0,115200
+endef
+
define Device/el-m150
$(Device/tplink-8mlzma)
BOARDNAME := EL-M150
@@ -353,7 +361,7 @@ define Device/el-mini
TPLINK_HWID := 0x01530001
CONSOLE := ttyATH0,115200
endef
-TARGET_DEVICES += antminer-s1 el-m150 el-mini
+TARGET_DEVICES += antminer-s1 antminer-s3 el-m150 el-mini
define Device/gl-inet-6408A-v1
$(Device/tplink-8mlzma)