aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-09-16 08:31:40 +0000
committerJohn Crispin <blogic@openwrt.org>2015-09-16 08:31:40 +0000
commiteedc48444ef34b1a1a4c93a56a3f2609f5bb47cb (patch)
tree066231f934314f137a793d40766d0ba555677de3 /target/linux/ar71xx/image/Makefile
parent917e16bbfb63cf1cbc1a055515c553dc3d32f4df (diff)
downloadmaster-187ad058-eedc48444ef34b1a1a4c93a56a3f2609f5bb47cb.tar.gz
master-187ad058-eedc48444ef34b1a1a4c93a56a3f2609f5bb47cb.tar.bz2
master-187ad058-eedc48444ef34b1a1a4c93a56a3f2609f5bb47cb.zip
ar71xx: Add UBNT airGateway Pro support
This patch adds kernel and userspace support for the Ubiquiti Networks airGateway Pro. Signed-off-by: Matthew Reeve <mreeve at tenxnetworks.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46961 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/image/Makefile')
-rw-r--r--target/linux/ar71xx/image/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 0becd24857..a8b8ecb8be 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -883,6 +883,15 @@ define Device/ubnt-air-gateway
endef
TARGET_DEVICES += ubnt-air-gateway
+define Device/ubnt-air-gateway-pro
+ $(Device/ubnt-xm)
+ BOARDNAME := UBNT-AGWP
+ UBNT_TYPE := AirGWP
+ UBNT_CHIP := ar934x
+ CONSOLE = ttyS0,115200
+endef
+TARGET_DEVICES += ubnt-air-gateway-pro
+
define Device/ubdev01
$(Device/ubnt-xm)
MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,7488k(firmware),64k(certs),256k(cfg)ro,64k(EEPROM)ro