aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2016-02-12 08:31:32 +0000
committerJohn Crispin <blogic@openwrt.org>2016-02-12 08:31:32 +0000
commitde350dcae493b2b71a0850b1d1d4ee0483552faa (patch)
treebb7c3e46f05b6304ef21dfc2697b32e23fe62206 /target/linux/ar71xx/image/Makefile
parenta6a72a79b71473f876b066444ef36279c58f885f (diff)
downloadmaster-187ad058-de350dcae493b2b71a0850b1d1d4ee0483552faa.tar.gz
master-187ad058-de350dcae493b2b71a0850b1d1d4ee0483552faa.tar.bz2
master-187ad058-de350dcae493b2b71a0850b1d1d4ee0483552faa.zip
ar71xx: Support for Ubiquiti UniFi AP AC LITE
Add support for the Ubiquiti UniFi AP AC LITE Signed-off-by: P.Wassi <p.wassi at gmx.at> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48711 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/image/Makefile')
-rw-r--r--target/linux/ar71xx/image/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 1bb0ac95bc..a77004181d 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -1141,12 +1141,21 @@ define Device/ubnt-unifi
DEVICE_PROFILE := UBNT UBNTUNIFI
endef
+define Device/ubnt-unifiac
+ DEVICE_PROFILE := UBNT UBNTUNIFIAC
+ IMAGE_SIZE := 7744k
+ MTDPARTS = spi0.0:384k(u-boot)ro,64k(u-boot-env)ro,7744k(firmware),7744k(ubnt-airos)ro,128k(bs)ro,256k(cfg)ro,64k(EEPROM)ro
+ IMAGES := sysupgrade.bin
+ IMAGE/sysupgrade.bin = append-kernel $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
+ BOARDNAME := UBNT-UF-AC
+endef
+
define Device/ubnt-unifi-outdoor
$(Device/ubnt-bz)
BOARDNAME := UBNT-U20
DEVICE_PROFILE := UBNT UBNTUNIFIOUTDOOR
endef
-TARGET_DEVICES += ubnt-unifi ubnt-unifi-outdoor
+TARGET_DEVICES += ubnt-unifi ubnt-unifiac ubnt-unifi-outdoor
define Device/ubnt-nano-m-xw
$(Device/ubnt-xw)