aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-10-11 16:23:44 +0000
committerJohn Crispin <blogic@openwrt.org>2015-10-11 16:23:44 +0000
commitd27b94ce065fb12acb16f0607ce8ede632634360 (patch)
tree7985683f9da1496a42e5542a5cd0cc4a25fe15f5 /target/linux/ar71xx/image/Makefile
parent7af02f0d011c546c42a105795ade5a1e5b56b7b1 (diff)
downloadmaster-187ad058-d27b94ce065fb12acb16f0607ce8ede632634360.tar.gz
master-187ad058-d27b94ce065fb12acb16f0607ce8ede632634360.tar.bz2
master-187ad058-d27b94ce065fb12acb16f0607ce8ede632634360.zip
ar71xx/image: add options argument to mktplinkfw step
Allow to pass extra arguments to mktplinkfw step. Some board requires an extra argument to create a valid image. Signed-off-by: Alexander Couzens <lynxis@fe80.eu> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47174 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/image/Makefile')
-rw-r--r--target/linux/ar71xx/image/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index c90891716c..2dd7798f21 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -38,13 +38,16 @@ define Build/netgear-uImage
endef
# combine kernel and rootfs into one image
+# mktplinkfw <type> <optional extra arguments to mktplinkfw binary>
+# <type> is "sysupgrade" or "factory"
+#
# -a align the rootfs start on an <align> bytes boundary
# -j add jffs2 end-of-filesystem markers
# -s strip padding from end of the image
# -X reserve <size> bytes in the firmware image (hexval prefixed with 0x)
define Build/mktplinkfw
-$(STAGING_DIR_HOST)/bin/mktplinkfw \
- -H $(TPLINK_HWID) -W $(TPLINK_HWREV) -F $(TPLINK_FLASHLAYOUT) -N OpenWrt -V $(REVISION) \
+ -H $(TPLINK_HWID) -W $(TPLINK_HWREV) -F $(TPLINK_FLASHLAYOUT) -N OpenWrt -V $(REVISION) $2 \
-k $(word 1,$^) \
-r $@ \
-o $@.new \
@@ -64,10 +67,12 @@ define Build/mktplinkfw-chn-v2
$(if $(findstring sysupgrade,$1),-s) && mv $@.new $@ || rm -f $@
endef
+# mktplinkfw-initramfs <optional extra arguments to mktplinkfw binary>
+#
# -c combined image
define Build/mktplinkfw-initramfs
$(STAGING_DIR_HOST)/bin/mktplinkfw \
- -H $(TPLINK_HWID) -W $(TPLINK_HWREV) -F $(TPLINK_FLASHLAYOUT) -N OpenWrt -V $(REVISION) \
+ -H $(TPLINK_HWID) -W $(TPLINK_HWREV) -F $(TPLINK_FLASHLAYOUT) -N OpenWrt -V $(REVISION) $2 \
-k $@ \
-o $@.new \
-s -S \