aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-11-07 12:51:43 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-11-07 12:51:43 +0000
commitbafb0e8a02cab036ff1be2948d9e78abddc51a56 (patch)
tree1155cfe2e85f46037ded6477ac7b5627d36a6189 /target/linux/ar71xx/image/Makefile
parent35e062080a818d43a05815015a7751bd1e36a2c1 (diff)
downloadmaster-187ad058-bafb0e8a02cab036ff1be2948d9e78abddc51a56.tar.gz
master-187ad058-bafb0e8a02cab036ff1be2948d9e78abddc51a56.tar.bz2
master-187ad058-bafb0e8a02cab036ff1be2948d9e78abddc51a56.zip
ar71xx: add support for the TP-LINK TL-WR1043ND v3
The hardware of the v3 is identical to the v2. Based-on-patch-by: Andreas Ziegler <github@andreas-ziegler.de> Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47406 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/image/Makefile')
-rw-r--r--target/linux/ar71xx/image/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 29e5064909..09e5394fd9 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -804,7 +804,14 @@ define Device/tl-wr1043nd-v2
DEVICE_PROFILE := TLWR1043
TPLINK_HWID := 0x10430002
endef
-TARGET_DEVICES += tl-wr1043nd-v1 tl-wr1043nd-v2
+
+define Device/tl-wr1043nd-v3
+ $(Device/tplink-8mlzma)
+ BOARDNAME := TL-WR1043ND-v2
+ DEVICE_PROFILE := TLWR1043
+ TPLINK_HWID := 0x10430003
+endef
+TARGET_DEVICES += tl-wr1043nd-v1 tl-wr1043nd-v2 tl-wr1043nd-v3
define Device/tl-wr2543-v1
$(Device/tplink-8mlzma)